summaryrefslogtreecommitdiff
path: root/dev-libs/botan/botan-2.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-libs/botan/botan-2.9.0.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-libs/botan/botan-2.9.0.ebuild')
-rw-r--r--dev-libs/botan/botan-2.9.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-libs/botan/botan-2.9.0.ebuild b/dev-libs/botan/botan-2.9.0.ebuild
index 8f92905d738a..90a1e9416b8d 100644
--- a/dev-libs/botan/botan-2.9.0.ebuild
+++ b/dev-libs/botan/botan-2.9.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
inherit multilib python-r1 toolchain-funcs
@@ -12,7 +12,7 @@ DESCRIPTION="A C++ crypto library"
HOMEPAGE="https://botan.randombit.net/"
SRC_URI="https://botan.randombit.net/releases/${MY_P}.tgz"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+KEYWORDS="amd64 ~arm ~hppa ~ia64 ppc ppc64 ~sparc x86 ~ppc-macos"
SLOT="2/$(ver_cut 1-2)" # soname version
LICENSE="BSD"
IUSE="bindist doc boost python bzip2 libressl lzma sqlite ssl static-libs zlib"
@@ -34,6 +34,10 @@ RDEPEND="${DEPEND}
BDEPEND="dev-lang/python:*
doc? ( dev-python/sphinx )"
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
src_configure() {
local disable_modules=()
use boost || disable_modules+=( "boost" )