summaryrefslogtreecommitdiff
path: root/dev-libs/botan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-03 16:17:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-03 16:17:22 +0000
commit4cd2370bed609c118b6edfde5d3f116e5c35b897 (patch)
treeec58f2c41f49754e41521d5ebc9dce4597ddd0a5 /dev-libs/botan
parentf443475c824b4b5c086e6d040961cb35ad81bc60 (diff)
gentoo resync : 03.12.2017
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/Manifest1
-rw-r--r--dev-libs/botan/botan-9999.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index ed0782ea4d00..8731eeb02b41 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -5,4 +5,5 @@ DIST Botan-1.10.17.tgz 2706678 SHA256 6847ffb64b8d2f939dccfecc17bd2c80385d08f762
DIST Botan-2.3.0.tgz 5947072 BLAKE2B b8eaf4228c01200f839031b423901f93c1b6863d10424ad52afeac85131e95bc1bad024478c8e4c8e4c12210e85aa62d30fb83b3ece8facdb57763f95c45687c SHA512 a8575bdb2eaa01fb45d8565bea0b54ddf47a21d2fb761fc0a286373b09d51e5a00e84d5cefc51040c5720db66f5625c6bc73ab09cffa9cd42472545610f9892a
EBUILD botan-1.10.17.ebuild 4215 BLAKE2B b4d1e16b4ed8ab4f8dfba08312c26b744896a59b3eaeed8df784ffd1ef8d81233eaf841270fa0e761ae9491797aa2ae965d4a8f0704140c5761263103fe856e1 SHA512 a8134be2cb93db31e468c7b1dc3559cbd6e54c32d36848df4597da7a49ca8d8d027ff9695393d6902e06dbdf101eac1ef55542bef366ce8ed334f2a7fe8e4b0c
EBUILD botan-2.3.0.ebuild 2783 BLAKE2B c65f5c4b2c84305bb10bf38439e34b25545d6ff7c06be17fcf276c87b4513b353d713075de183c92c701f9b161c949be081e5b874ac31b9b87917b04050d1092 SHA512 49471ee62fdc03e9a058ba90b7e2260b8bee4cad677d804a35ccf4e22d2179220497e0cc47733d80974f7af686ae10a68164babc27586e0ebd155d7b32526a45
+EBUILD botan-9999.ebuild 2251 BLAKE2B d3bfb15560fca7cbaed2614ec87503e9021e4d5f76a63d4c55a868966a71316425146e81c485ac7e7eec6db5b0b03a77fa56f7c98185da3c427fb25314d95911 SHA512 b335208dc9bbaaba49c5e71cc8a5e49b210113a16f5362874ccf9dd035e86c0a10445fbc37ee9dcb6da1c681caaacb770b5149149c71b106091011cf596fdfce
MISC metadata.xml 675 BLAKE2B 20c2dc44426b9e2c7d57f45b5838b0ca27d80e6cbef49471cfe1cafb3c5db47ec3f243736856550bda25fd21e12fef08a71f6db7d855a025a3f4133fd2b5a1d7 SHA512 6773167b2e46f8d2251d369bd668a2ea309ce3b874166ebd102c7758f1f23a215f47d6581999d49325e9fdda88082ab46db8dc4f98ad6a20722f50a56b474b39
diff --git a/dev-libs/botan/botan-9999.ebuild b/dev-libs/botan/botan-9999.ebuild
new file mode 100644
index 000000000000..64cfdba155d9
--- /dev/null
+++ b/dev-libs/botan/botan-9999.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit multilib python-r1 toolchain-funcs
+inherit git-r3
+
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+EGIT_REPO_URI="https://github.com/randombit/botan"
+
+KEYWORDS=""
+SLOT="2/3" # soname version
+LICENSE="BSD"
+IUSE="bindist doc boost python bzip2 libressl lzma sqlite ssl static-libs zlib"
+
+RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )
+ boost? ( >=dev-libs/boost-1.48 )
+ lzma? ( app-arch/xz-utils )
+ sqlite? ( dev-db/sqlite:3 )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}
+ dev-lang/python:*
+ doc? ( dev-python/sphinx )"
+
+src_prepare() {
+ default
+ use python && python_copy_sources
+}
+
+src_configure() {
+ local disable_modules=()
+ use boost || disable_modules+=( "boost" )
+ use bindist && disable_modules+=( "ecdsa" )
+ elog "Disabling modules: ${disable_modules[@]}"
+
+ # Enable v9 instructions for sparc64
+ if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
+ CHOSTARCH="sparc32-v9"
+ else
+ CHOSTARCH="${CHOST%%-*}"
+ fi
+
+ local myos=
+ case ${CHOST} in
+ *-darwin*) myos=darwin ;;
+ *) myos=linux ;;
+ esac
+
+ local pythonvers=()
+ if use python; then
+ append() {
+ pythonvers+=( ${EPYTHON/python/} )
+ }
+ python_foreach_impl append
+ fi
+
+ CXX="$(tc-getCXX)" AR="$(tc-getAR)" ./configure.py \
+ --prefix="${EPREFIX}/usr" \
+ --libdir=$(get_libdir) \
+ --docdir=share/doc \
+ --cc=gcc \
+ --os=${myos} \
+ --cpu=${CHOSTARCH} \
+ --with-endian="$(tc-endian)" \
+ --without-doxygen \
+ $(use_with bzip2) \
+ $(use_with lzma) \
+ $(use_with sqlite sqlite3) \
+ $(use_with ssl openssl) \
+ $(use_with zlib) \
+ $(use_with boost) \
+ $(use_with doc sphinx) \
+ $(use_with doc documentation) \
+ $(use_enable static-libs static-library) \
+ --with-python-version=$(IFS=","; echo "${pythonvers[*]}" ) \
+ --disable-modules=$(IFS=","; echo "${disable_modules[*]}" ) \
+ || die "configure.py failed"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
+}
+
+src_install() {
+ default
+ use python && python_foreach_impl python_optimize
+}