summaryrefslogtreecommitdiff
path: root/dev-libs/botan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-libs/botan
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/Manifest2
-rw-r--r--dev-libs/botan/botan-2.7.0.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index 71f1dfb12cef..6d2bacc847d9 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -2,6 +2,8 @@ AUX botan-1.10.17-build.patch 874 BLAKE2B 94898dc7730c921ea4a545fdad5d5eeb91432e
AUX botan-1.10.17-libressl.patch 1344 BLAKE2B e465b852e17ce920022663a8ea25684b2340fff699eb4b89d97784ffbec9e395200ffb2b9aa2226448e199f51a176409ed086e909c4ae431ede21c66d3de334b SHA512 dee61a141a10572c4d4c111527bbca3bd77808a2642ddb9cb105785badc10babd0406b1634c62c355e5361b9281c989666851d0fb81b3e000b62570e429fd642
DIST Botan-1.10.17.tgz 2706678 BLAKE2B bce65493c702381aaa747c2b935c545f85704b93bb6be4bf225048cc14812999291bbbe86786c2b00865489ec47d63128b12ef1020be8651be57fa1c84006a7c SHA512 a47cab3af113652247c8efc8b0f043eb62175eaa8554833d5fc3016ea94dbdd8aa722ab9b5226cc5f133afbcc088d54362111630eaa4594812c39925cc3c8649
DIST Botan-2.6.0.tgz 6599127 BLAKE2B c45a974f89571c1050e28108267ca6ec094171be3d7dbcb033b86b7dac3f8074703c40c42d5737074a86c19266b4b47c266d0864ce08ee26fad05116a50c48a8 SHA512 2082b4aaac0802f117a5f75c67a69e6d364b436a0ebe543032e370c3f085752bbe1ca48051462066e13bd42e47573ebc532d1d45074fe406df032f33346ee645
+DIST Botan-2.7.0.tgz 7021654 BLAKE2B 3f18b7ba660a72a409beeaba8bd1b1bd021f645c135bed56d75b6ba906b7c28d1e14eac9550862500dda9c4b3ac3135cfc9c340e073c573deb66b236e09f8054 SHA512 992138d83e18aedf80337d825f80c34dd3d2177eb30967573c57cf9fb7e7f9a9965ae3d75f23635f4c93b4efb7bb5adbb3423702663c78a5eb905dd567561858
EBUILD botan-1.10.17.ebuild 4221 BLAKE2B 463e3e2b0893b5c9330c7d317fb089f70cc8adf2f60654711674bfb1eeb3c2b34e44e5695b230078510821cb7f45a23745016ebfd6c30cc660d6a132f4ef3223 SHA512 00065423d5f3600a08542e8722ce63dcf6147bce0b2104e466acf444c7e107f191652b588d7b7054652099cb89973b646987084c39678a8472d565249e064f6b
EBUILD botan-2.6.0.ebuild 2339 BLAKE2B f3871202e70810f7003a16a02befc4bf69ff04baa451a80a2bfb13a96cb1cbc645a1f622941c9af27b2a6b8617fe69f81d601a1fc0738ac4f922465a8014277a SHA512 f46c844b7df21647876f933f4263427625fc2da6a6688c5333f4205fad06da0c99a68de152036778ba0a6b4890b772c8e41f95687786e6153ace2d52856be3b2
+EBUILD botan-2.7.0.ebuild 2343 BLAKE2B f1afad9cd5595cd440c4c5690a89bcb3221479bebae4d55b2655a87e05e894667fca6f065de30dd825d777fff644830d9cd675978097f6fb4c244cce29ba0ee6 SHA512 cace49e3060744b8470a1e71a3f24f0469808d4f5f0c6a6fa71d4fcf1304a90af3b62396ece497d7c84b9bb8e8c73835007e710059892dd8f108bebc07d86c4a
MISC metadata.xml 610 BLAKE2B a74ed3478dcf62ad762a113e594c660656d52352e569d4eaa54c47009505a869c4e553a8f8330b0b2ad9dae88b7b2bc6d44ede1f2dd330da9ff01240f56eed29 SHA512 9d14b7f0222b9b169f8ae60798d1a9ac551004bcbd0344451409cdb1cbefaaf70760a2f443f0c793265492387ca28f7dccd293bd30585a014a72f2a21eee1561
diff --git a/dev-libs/botan/botan-2.7.0.ebuild b/dev-libs/botan/botan-2.7.0.ebuild
new file mode 100644
index 000000000000..5b1383c390d7
--- /dev/null
+++ b/dev-libs/botan/botan-2.7.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit multilib python-r1 toolchain-funcs versionator
+
+MY_PN="Botan"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="https://botan.randombit.net/"
+SRC_URI="https://botan.randombit.net/releases/${MY_P}.tgz"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+SLOT="2/$(get_version_component_range 2)" # soname version
+LICENSE="BSD"
+IUSE="bindist doc boost python bzip2 libressl lzma sqlite ssl static-libs zlib"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )
+ boost? ( >=dev-libs/boost-1.48 )
+ lzma? ( app-arch/xz-utils )
+ sqlite? ( dev-db/sqlite:3 )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}
+ dev-lang/python:*
+ doc? ( dev-python/sphinx )"
+
+src_configure() {
+ local disable_modules=()
+ use boost || disable_modules+=( "boost" )
+ use bindist && disable_modules+=( "ecdsa" )
+ elog "Disabling modules: ${disable_modules[@]}"
+
+ # Enable v9 instructions for sparc64
+ if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
+ CHOSTARCH="sparc32-v9"
+ else
+ CHOSTARCH="${CHOST%%-*}"
+ fi
+
+ local myos=
+ case ${CHOST} in
+ *-darwin*) myos=darwin ;;
+ *) myos=linux ;;
+ esac
+
+ local pythonvers=()
+ if use python; then
+ append() {
+ pythonvers+=( ${EPYTHON/python/} )
+ }
+ python_foreach_impl append
+ fi
+
+ CXX="$(tc-getCXX)" AR="$(tc-getAR)" ./configure.py \
+ --prefix="${EPREFIX}/usr" \
+ --libdir=$(get_libdir) \
+ --docdir=share/doc \
+ --cc=gcc \
+ --os=${myos} \
+ --cpu=${CHOSTARCH} \
+ --with-endian="$(tc-endian)" \
+ --without-doxygen \
+ $(use_with bzip2) \
+ $(use_with lzma) \
+ $(use_with sqlite sqlite3) \
+ $(use_with ssl openssl) \
+ $(use_with zlib) \
+ $(use_with boost) \
+ $(use_with doc sphinx) \
+ $(use_with doc documentation) \
+ $(use_enable static-libs static-library) \
+ --with-python-version=$(IFS=","; echo "${pythonvers[*]}" ) \
+ --disable-modules=$(IFS=","; echo "${disable_modules[*]}" ) \
+ || die "configure.py failed"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}" ./botan-test || die "Validation tests failed"
+}
+
+src_install() {
+ default
+ use python && python_foreach_impl python_optimize
+}