summaryrefslogtreecommitdiff
path: root/dev-libs/cJSON/cJSON-1.7.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-15 22:41:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-15 22:41:20 +0100
commit7a0f8a92967dc1c6eab8d6f66ec476905009a287 (patch)
treeb73eed0b6ba49f9ca7e90538a00999ac22531f9c /dev-libs/cJSON/cJSON-1.7.16.ebuild
parent35d4e80ab08982deb97a95d1b47156c67b268492 (diff)
gentoo auto-resync : 15:07:2023 - 22:41:20
Diffstat (limited to 'dev-libs/cJSON/cJSON-1.7.16.ebuild')
-rw-r--r--dev-libs/cJSON/cJSON-1.7.16.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/cJSON/cJSON-1.7.16.ebuild b/dev-libs/cJSON/cJSON-1.7.16.ebuild
new file mode 100644
index 000000000000..8eab77565cca
--- /dev/null
+++ b/dev-libs/cJSON/cJSON-1.7.16.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Ultralightweight JSON parser in ANSI C"
+HOMEPAGE="https://github.com/DaveGamble/cJSON"
+SRC_URI="https://github.com/DaveGamble/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -i -e '/-Werror/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CJSON_TEST=$(usex test)
+ )
+
+ cmake_src_configure
+}