summaryrefslogtreecommitdiff
path: root/dev-libs/capstone/capstone-4.0.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-libs/capstone/capstone-4.0.2-r2.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-libs/capstone/capstone-4.0.2-r2.ebuild')
-rw-r--r--dev-libs/capstone/capstone-4.0.2-r2.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/dev-libs/capstone/capstone-4.0.2-r2.ebuild b/dev-libs/capstone/capstone-4.0.2-r2.ebuild
index 99f181cb326c..09477aff2a6e 100644
--- a/dev-libs/capstone/capstone-4.0.2-r2.ebuild
+++ b/dev-libs/capstone/capstone-4.0.2-r2.ebuild
@@ -4,9 +4,9 @@
EAPI=7
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit cmake-utils distutils-r1 toolchain-funcs
+inherit cmake distutils-r1 toolchain-funcs
DESCRIPTION="disassembly/disassembler framework + bindings"
HOMEPAGE="http://www.capstone-engine.org/"
@@ -25,6 +25,9 @@ DEPEND="${RDEPEND}
"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+#TODO: needs upstream fixes
+#distutils_enable_tests setup.py
+
S=${WORKDIR}/${P/_rc/-rc}
PATCHES=(
@@ -32,15 +35,20 @@ PATCHES=(
)
wrap_python() {
+ local phase=$1
+ shift
+
if use python; then
pushd bindings/python >/dev/null || die
- distutils-r1_${1} "$@"
+ echo distutils-r1_${phase} "$@"
+ pwd
+ distutils-r1_${phase} "$@"
popd >/dev/null
fi
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
wrap_python ${FUNCNAME}
}
@@ -50,25 +58,25 @@ src_configure() {
-DCAPSTONE_BUILD_TESTS="$(usex test)"
-DCAPSTONE_BUILD_STATIC="$(usex static-libs)"
)
- cmake-utils_src_configure
+ cmake_src_configure
wrap_python ${FUNCNAME}
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
wrap_python ${FUNCNAME}
}
src_test() {
- cmake-utils_src_test
+ cmake_src_test
wrap_python ${FUNCNAME}
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
wrap_python ${FUNCNAME}
}