summaryrefslogtreecommitdiff
path: root/dev-libs/cdk/cdk-5.0.20141106.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/cdk/cdk-5.0.20141106.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/cdk/cdk-5.0.20141106.ebuild')
-rw-r--r--dev-libs/cdk/cdk-5.0.20141106.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/cdk/cdk-5.0.20141106.ebuild b/dev-libs/cdk/cdk-5.0.20141106.ebuild
new file mode 100644
index 000000000000..b1cc6ecfcfda
--- /dev/null
+++ b/dev-libs/cdk/cdk-5.0.20141106.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils versionator
+
+MY_P="${PN}-$(replace_version_separator 2 -)"
+DESCRIPTION="A library of curses widgets"
+HOMEPAGE="http://dickey.his.com/cdk/cdk.html"
+SRC_URI="ftp://invisible-island.net/cdk/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0/6" # subslot = soname version
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~s390 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="examples static-libs unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2[unicode?]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.0.20120323-parallel-make.patch
+}
+
+src_configure() {
+ econf \
+ --with-libtool \
+ --with-shared \
+ --with-ncurses$(usex unicode "w" "")
+}
+
+src_install() {
+ # parallel make installs duplicate libs
+ emake -j1 \
+ DESTDIR="${ED}" \
+ DOCUMENT_DIR="${ED}/usr/share/doc/${PF}" install
+
+ if use examples ; then
+ for x in include c++ demos examples cli cli/utils cli/samples; do
+ docinto $x
+ find $x -maxdepth 1 -mindepth 1 -type f -print0 | xargs -0 dodoc
+ done
+ fi
+
+ use static-libs || find "${ED}" \( -name '*.a' -or -name '*.la' \) -delete
+}