summaryrefslogtreecommitdiff
path: root/dev-libs/cl/cl-1.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /dev-libs/cl/cl-1.2.4.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'dev-libs/cl/cl-1.2.4.ebuild')
-rw-r--r--dev-libs/cl/cl-1.2.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/cl/cl-1.2.4.ebuild b/dev-libs/cl/cl-1.2.4.ebuild
new file mode 100644
index 000000000000..060444f5d50b
--- /dev/null
+++ b/dev-libs/cl/cl-1.2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils multilib
+
+DESCRIPTION="OpenCL bindings for Erlang"
+HOMEPAGE="https://github.com/tonyrog/cl"
+SRC_URI="${HOMEPAGE}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-lang/erlang-16
+ virtual/opencl
+ dev-util/rebar
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-${P}
+
+src_compile() {
+ rebar compile || die
+}
+
+src_install() {
+ ERLANG_DIR="/usr/$(get_libdir)/erlang/lib"
+ CL_DIR="${ERLANG_DIR}/${P}"
+ insinto "${CL_DIR}"
+ doins -r ebin src include c_src examples
+}