summaryrefslogtreecommitdiff
path: root/dev-libs/cppcodec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
commit1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (patch)
treec99a472cce74148d499f42ada873454b0e32a42d /dev-libs/cppcodec
parentda6a52f691ef980bab92d003d5df8f463c623af8 (diff)
gentoo resync : 13.03.2018
Diffstat (limited to 'dev-libs/cppcodec')
-rw-r--r--dev-libs/cppcodec/Manifest2
-rw-r--r--dev-libs/cppcodec/cppcodec-9999.ebuild38
-rw-r--r--dev-libs/cppcodec/metadata.xml12
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/cppcodec/Manifest b/dev-libs/cppcodec/Manifest
new file mode 100644
index 000000000000..8dab76fef9b6
--- /dev/null
+++ b/dev-libs/cppcodec/Manifest
@@ -0,0 +1,2 @@
+EBUILD cppcodec-9999.ebuild 774 BLAKE2B 0880b07c415b627079868c81c1a2d14f3442d274d8634784179b3616fb243dff643a32c280ec2ad0a94cc048fd05f3c7eb7390c5803d12afa5e7c454e4d1b40b SHA512 3e366dc7df756b3b588e302d2d4a86d0b02225cccaa005bbf3b2b7a80e3bba3fbc0c8afb36bf44ec66543fccb3f5dc14ae5aa0b1426af19f4bc5137d613f408f
+MISC metadata.xml 385 BLAKE2B b2d35f81b4df3fc6de6d0be3bb253131817980e55fb6b4e1f43c06ec07fb6bd4b6d102248873dd4b8831aa05139879a05953f0f6efccea05a1bb00e8cf5a94b1 SHA512 195de9b1b75f92cc00a943e8dcbda580d7994c0a94947fa964b46ab4ad979ffd85d6658d59908aafe8f265241bfb322eac1ec6586e403246c3eaedf7b2799c11
diff --git a/dev-libs/cppcodec/cppcodec-9999.ebuild b/dev-libs/cppcodec/cppcodec-9999.ebuild
new file mode 100644
index 000000000000..61c267ce9512
--- /dev/null
+++ b/dev-libs/cppcodec/cppcodec-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+inherit cmake-utils
+
+DESCRIPTION="C++11 library to encode/decode base64, base64url, base32, base32hex and hex"
+HOMEPAGE="https://github.com/tplgy/cppcodec"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tplgy/cppcodec.git"
+
+ # Disable pulling in catch
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/tplgy/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ test? (
+ virtual/pkgconfig
+ >=dev-cpp/catch-2.2.0
+ )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/cppcodec/metadata.xml b/dev-libs/cppcodec/metadata.xml
new file mode 100644
index 000000000000..fc886b24e5c5
--- /dev/null
+++ b/dev-libs/cppcodec/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>soap@gentoo.org</email>
+ <name>David Seifert</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tplgy/cppcodec</remote-id>
+ <bugs-to>https://github.com/tplgy/cppcodec/issues</bugs-to>
+ </upstream>
+</pkgmetadata>