summaryrefslogtreecommitdiff
path: root/dev-libs/ding-libs/ding-libs-0.6.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
commitb426a5cef3f0ebe3389686a1c145a834d3a1e120 (patch)
treeeee77f741af6979f620416c573e5203eab81c9c3 /dev-libs/ding-libs/ding-libs-0.6.2-r1.ebuild
parent97b176c73aa78bd33234884388e3978f520161c3 (diff)
gentoo auto-resync : 09:09:2022 - 10:40:04
Diffstat (limited to 'dev-libs/ding-libs/ding-libs-0.6.2-r1.ebuild')
-rw-r--r--dev-libs/ding-libs/ding-libs-0.6.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/ding-libs/ding-libs-0.6.2-r1.ebuild b/dev-libs/ding-libs/ding-libs-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..ccd6a03cf4f8
--- /dev/null
+++ b/dev-libs/ding-libs/ding-libs-0.6.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Set of utility libraries (mostly used by sssd)"
+HOMEPAGE="https://github.com/SSSD/ding-libs"
+SRC_URI="https://github.com/SSSD/ding-libs/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-libs/check )"
+BDEPEND="virtual/pkgconfig"
+
+src_install() {
+ default
+
+ # No static archives
+ find "${ED}" -name '*.la' -delete || die
+}