summaryrefslogtreecommitdiff
path: root/dev-libs/distorm3/distorm3-3.5.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-07 11:57:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-07 11:57:01 +0000
commitb3fef92e618039dc93153a93176184a49606c74a (patch)
treead9ab32cccd1125450feb872dd493ae07b6f4ffd /dev-libs/distorm3/distorm3-3.5.2-r1.ebuild
parent32f67cc4163d5c6e094345e920ada52367df5f5f (diff)
gentoo auto-resync : 07:03:2023 - 11:57:00
Diffstat (limited to 'dev-libs/distorm3/distorm3-3.5.2-r1.ebuild')
-rw-r--r--dev-libs/distorm3/distorm3-3.5.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/distorm3/distorm3-3.5.2-r1.ebuild b/dev-libs/distorm3/distorm3-3.5.2-r1.ebuild
new file mode 100644
index 000000000000..c623afc293d7
--- /dev/null
+++ b/dev-libs/distorm3/distorm3-3.5.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-lang/yasm )"
+
+PATCHES=( "${FILESDIR}"/${P}-under.patch )
+
+EPYTEST_DESELECT=(
+ # outdated tests? API usage mismatch
+ # https://github.com/gdabah/distorm/issues/173
+ python/test_distorm3.py::Test::test_dummy
+ python/test_distorm3.py::InstBin::test_dummy
+ python/test_distorm3.py::Inst::test_dummy
+)
+
+distutils_enable_tests pytest
+
+python_install() {
+ distutils-r1_python_install
+
+ # don't know why it does not happen by default
+ python_optimize
+}