summaryrefslogtreecommitdiff
path: root/dev-libs/dotconf/dotconf-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-09 18:31:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-09 18:31:35 +0100
commitfb7c221776ce0bda5eb40ef32cb74daa98aed0d7 (patch)
tree0da74e27cfe965ce494b4be29eb9b4d04dda8259 /dev-libs/dotconf/dotconf-1.4.1.ebuild
parent7e8f29e487b79a183d66ca22f1e54dab5c47a409 (diff)
gentoo auto-resync : 09:04:2024 - 18:31:35
Diffstat (limited to 'dev-libs/dotconf/dotconf-1.4.1.ebuild')
-rw-r--r--dev-libs/dotconf/dotconf-1.4.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/dotconf/dotconf-1.4.1.ebuild b/dev-libs/dotconf/dotconf-1.4.1.ebuild
new file mode 100644
index 000000000000..36d47ae81583
--- /dev/null
+++ b/dev-libs/dotconf/dotconf-1.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+fi
+inherit autotools toolchain-funcs
+
+DESCRIPTION="dot.conf configuration file parser"
+HOMEPAGE="https://github.com/williamh/dotconf"
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/williamh/dotconf.git"
+else
+ SRC_URI="https://github.com/williamh/dotconf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+DEPEND=">=dev-build/autoconf-2.58"
+
+src_configure() {
+ eautoreconf
+ econf --disable-static
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}