summaryrefslogtreecommitdiff
path: root/dev-libs/dqlite/dqlite-1.16.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-23 11:40:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-23 11:40:30 +0000
commitedca36e835d0d4e929c1dd3e9688954ae0aa191a (patch)
treec60f9dd076d4eff037c8ad746de4bf5d48e55b08 /dev-libs/dqlite/dqlite-1.16.3.ebuild
parent914bc7f07098ac3918913e4c83951a9cbba5a949 (diff)
gentoo auto-resync : 23:02:2024 - 11:40:30
Diffstat (limited to 'dev-libs/dqlite/dqlite-1.16.3.ebuild')
-rw-r--r--dev-libs/dqlite/dqlite-1.16.3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/dqlite/dqlite-1.16.3.ebuild b/dev-libs/dqlite/dqlite-1.16.3.ebuild
new file mode 100644
index 000000000000..832370126c90
--- /dev/null
+++ b/dev-libs/dqlite/dqlite-1.16.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Embeddable, replicated and fault tolerant SQL engine"
+HOMEPAGE="https://dqlite.io/ https://github.com/canonical/dqlite"
+SRC_URI="https://github.com/canonical/dqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/1.15.1"
+KEYWORDS="amd64 ~arm64 ~x86"
+IUSE="lz4 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/libuv:=
+ lz4? ( app-arch/lz4:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/dqlite-1.12.0-disable-werror.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-backtrace
+ --disable-debug
+ --disable-sanitize
+ --disable-static
+
+ # Will use bundled raft instead of system raft. See bugs #915960, #925012.
+ --enable-build-raft
+
+ # Will build a bundled libsqlite3.so.
+ --enable-build-sqlite=no
+
+ $(use_with lz4)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}