summaryrefslogtreecommitdiff
path: root/dev-libs/fampp2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/fampp2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/fampp2')
-rw-r--r--dev-libs/fampp2/Manifest6
-rw-r--r--dev-libs/fampp2/fampp2-7.0.1-r3.ebuild59
-rw-r--r--dev-libs/fampp2/files/fampp2-7.0.1-fix-buildsystem.patch78
-rw-r--r--dev-libs/fampp2/files/fampp2-7.0.1-fix-gcc6.patch67
-rw-r--r--dev-libs/fampp2/files/fampp2-7.0.1-libsigc++-2.6.patch46
-rw-r--r--dev-libs/fampp2/metadata.xml11
6 files changed, 267 insertions, 0 deletions
diff --git a/dev-libs/fampp2/Manifest b/dev-libs/fampp2/Manifest
new file mode 100644
index 000000000000..2cd619f51fd0
--- /dev/null
+++ b/dev-libs/fampp2/Manifest
@@ -0,0 +1,6 @@
+AUX fampp2-7.0.1-fix-buildsystem.patch 1882 BLAKE2B 2726865322fc1de809d974889b40cda6b8051efd67b9d2d4cf649d226fcc6933332899b6e73722c69e31b14048921c6db70992813035d4c0e418b00c2eff7594 SHA512 00241839c238d772803dc095e1eaa81eadf9451f2c8a783d4d5acbcaa82b755d00e6ec6bdb2a6e621427e10a0f0674d92186b58bb28a708c3f714200b626caa4
+AUX fampp2-7.0.1-fix-gcc6.patch 1514 BLAKE2B b94986a1166089672d1e5d229bee1b3902eaa051d8c427bf5d85fce7df3b2eeaefcccad2e98f22637d8406784b57d49ed63e0d4606036b2eaf8bf9e125295820 SHA512 2c41ecae31cb6bb5df861cd56f0898e9dcf4f5d71f1b25462989548847e4bf7b0f96dc1b53a139dc6b72a251e283e2e7f540dd751f045bc06061193f4b4787cb
+AUX fampp2-7.0.1-libsigc++-2.6.patch 1041 BLAKE2B 33c0c437602c48008599cf6ea670e2ad6fe1fd7b41d6c16860a7ac559435e5ea8a5c0d583d53afee13f7d0a23a685160877bca45dec1574885bfdf50323c5402 SHA512 6139c238551b4dd8396ed7df23353245b7668a27c109da3f720acc582d6b08d0b6f3227924ea8ca4c101706eae9036aa84f7f5ecd91c41f0f54d700a73a49b55
+DIST fampp2-7.0.1.tar.bz2 288073 BLAKE2B f74659c83af82eeed6c5f711a9273f2d8c7704f04c8407992bee7478d2ef20b6d2ecf37c5d292be35c126474052341c49f8a0d30d056c24e2404b17d0123dfd7 SHA512 317a5cfd383418265cafea0840af8b7c714a04b34265ebfba73230ff2492df8f7884797529916693ab489bdbc94799ca83e015cf0bcfffaea6b28b3a7f9ccbd0
+EBUILD fampp2-7.0.1-r3.ebuild 1234 BLAKE2B 810284de8a066038277b1388e105b707c5a2877d865d1691ea54afcd2cffe3cf7a27c9816ff202d33fd8f60eb995a688e8a76d2f269d86c57c87487898580cce SHA512 51f1696cf3eb0e5efde0bfa586e0f6e99afb2b06ec1beaa4f9d222ffc92655dcea14e1a5e3feaa6a4cd4097d6f764e06a155dac739971ff3debf66b2daefc789
+MISC metadata.xml 324 BLAKE2B af36dbfa1fbe2235c3e7a28d4bb6ce2eb03b7d5a5918e010bc0cf7b171bdd5a160eeed79d2eac315b93628115e3af8d6e85f42355eca162875b2768adfdbd92c SHA512 c87cbdc39f88103e6ebb534a0c65a3ea4ae784a198a5286c7d43d935386588a7900e27894b9f6d552fd199b4c4fc2fa7daad7624145976cc8c82f61ddd327fc0
diff --git a/dev-libs/fampp2/fampp2-7.0.1-r3.ebuild b/dev-libs/fampp2/fampp2-7.0.1-r3.ebuild
new file mode 100644
index 000000000000..7854cb30ecee
--- /dev/null
+++ b/dev-libs/fampp2/fampp2-7.0.1-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="C++ wrapper for fam"
+HOMEPAGE="https://sourceforge.net/projects/fampp/"
+SRC_URI="mirror://sourceforge/fampp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-libs/ferrisloki-2.0.3
+ dev-libs/glib:2
+ >=dev-libs/libsigc++-2.6:2
+ virtual/fam
+ x11-libs/gtk+:2"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ # Fix compat with libsigc++-2.6, #569700
+ "${FILESDIR}/${PN}-7.0.1-libsigc++-2.6.patch"
+ # Fix completely broken buildsystem
+ "${FILESDIR}/${PN}-7.0.1-fix-buildsystem.patch"
+ # Fix noexcept(true) for dtors in >=C++11 with GCC 6, #595308
+ "${FILESDIR}/${PN}-7.0.1-fix-gcc6.patch"
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ # libsigc++-2.6 requires building with C++11
+ append-cxxflags -std=c++11
+
+ # glib and gtk+ are only required for some examples
+ econf \
+ --disable-static \
+ --disable-glibtest \
+ --disable-gtktest \
+ --disable-stlport \
+ $(use_with examples)
+}
+
+src_install() {
+ default
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/fampp2/files/fampp2-7.0.1-fix-buildsystem.patch b/dev-libs/fampp2/files/fampp2-7.0.1-fix-buildsystem.patch
new file mode 100644
index 000000000000..34067ff1f539
--- /dev/null
+++ b/dev-libs/fampp2/files/fampp2-7.0.1-fix-buildsystem.patch
@@ -0,0 +1,78 @@
+Fix buildsystem, to avoid ugly and extremely brittle patching
+of the configure script and Makefile.in in the main ebuild.
+
+--- a/configure.in
++++ b/configure.in
+@@ -1,8 +1,8 @@
++AC_PREREQ([2.69])
++AC_INIT([fampp2],[7.0.1])
+
+-# require autoconf 2.13
+-AC_PREREQ(2.13)
+-
+-AC_INIT(src/Fampp2.hh)
++AC_CONFIG_MACRO_DIR([macros])
++AC_CONFIG_SRCDIR([src/Fampp2.hh])
+
+ FAMPPTWO_MAJOR=7
+ FAMPPTWO_MINOR=0
+@@ -22,9 +22,8 @@
+ VERSION=$FAMPP_VERSION
+ PACKAGE=fampp2
+
+-AM_CONFIG_HEADER(config.h)
+-AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
+-AM_MAINTAINER_MODE
++AC_CONFIG_HEADERS([config.h])
++AM_INIT_AUTOMAKE
+
+ AC_CANONICAL_HOST
+ AC_ISC_POSIX
+@@ -33,11 +32,7 @@
+ AC_PROG_CPP
+ AC_PROG_CXX
+
+-AC_STDC_HEADERS
+-#AC_ARG_PROGRAM
+-AC_DISABLE_FAST_INSTALL
+-AC_DISABLE_STATIC
+-AM_PROG_LIBTOOL
++LT_INIT
+
+
+ dnl Checks for libraries.
+@@ -58,15 +53,12 @@
+ ###############################################################################
+
+
+-CFLAGS=" $STLPORT_CFLAGS $LOKI_CFLAGS $SIGC_CFLAGS $CFLAGS -O0 -g "
+-CXXFLAGS=" $STLPORT_CFLAGS $CXXFLAGS -O0 -g $LOKI_LIBS $SIGC_CFLAGS "
+-LDFLAGS=" $STLPORT_LIBS $SIGC_LIBS $LDFLAGS -Wl,-O1 -Wl,--hash-style=both"
+-AC_SUBST(CFLAGS)
+-AC_SUBST(CPPFLAGS)
+-AC_SUBST(LDFLAGS)
+-AC_SUBST(CXXFLAGS)
+-AC_SUBST(CXXCPPFLAGS)
++CFLAGS="${CFLAGS} ${STLPORT_CFLAGS} ${LOKI_CFLAGS} ${SIGC_CFLAGS}"
++CXXFLAGS="${CXXFLAGS} ${STLPORT_CFLAGS} ${LOKI_CFLAGS} ${SIGC_CFLAGS}"
++LIBS="${LIBS} ${STLPORT_LIBS} ${LOKI_LIBS} ${SIGC_LIBS}"
+
++AC_ARG_WITH([examples], [install examples])
++AM_CONDITIONAL([EXAMPLES], [test "x$with_examples" = "xyes"])
+
+ dnl if test "x${prefix}" = 'xNONE'; then
+ dnl prefix=${ac_default_prefix};
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,7 +1,10 @@
+ AUTOMAKE_OPTIONS = dist-bzip2 subdir-objects
+
+ NULL=
+-SUBDIRS = src examples
++SUBDIRS = src
++if EXAMPLES
++SUBDIRS += examples
++endif
+
+ EXTRA_DIST = fampp.spec fampp.spec.in fampp2.pc.in fampp2.pc
+
diff --git a/dev-libs/fampp2/files/fampp2-7.0.1-fix-gcc6.patch b/dev-libs/fampp2/files/fampp2-7.0.1-fix-gcc6.patch
new file mode 100644
index 000000000000..659ecd51bf4c
--- /dev/null
+++ b/dev-libs/fampp2/files/fampp2-7.0.1-fix-gcc6.patch
@@ -0,0 +1,67 @@
+C++11 changed destructor semantics to be noexcept(true)
+by default, leading to potentially changed semantics.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=595308
+
+--- a/src/Fampp2.cpp
++++ b/src/Fampp2.cpp
+@@ -105,6 +105,9 @@
+ // #include <unistd.h>
+
+ FamppRequest::~FamppRequest()
++#if __cplusplus >= 201103L
++ noexcept(false)
++#endif
+ {
+ // cerr << "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!" << endl;
+ // cerr << "FamppRequest::~FamppRequest() this:" << (void*)this << endl;
+@@ -245,6 +248,9 @@
+
+
+ FamppImplMethods::~FamppImplMethods()
++#if __cplusplus >= 201103L
++ noexcept(false)
++#endif
+ {
+ if(0 != FAMClose( &theFAMConnection )) {
+ throw FamppCloseFailedException();
+--- a/src/Fampp2.hh
++++ b/src/Fampp2.hh
+@@ -168,7 +168,11 @@
+ public:
+
+
+- ~FamppRequest();
++ ~FamppRequest()
++#if __cplusplus >= 201103L
++ noexcept(false)
++#endif
++ ;
+
+
+ void suspend();
+@@ -216,7 +220,11 @@
+ protected:
+
+ FamppImplMethods();
+- virtual ~FamppImplMethods();
++ virtual ~FamppImplMethods()
++#if __cplusplus >= 201103L
++ noexcept(false)
++#endif
++ ;
+
+
+ public:
+@@ -251,7 +259,11 @@
+ public:
+ FamppSingletonClass();
+ FamppSingletonClass(const std::string appName);
+- ~FamppSingletonClass();
++ ~FamppSingletonClass()
++#if __cplusplus >= 201103L
++ noexcept(false)
++#endif
++ ;
+
+
+ void NextEvent();
diff --git a/dev-libs/fampp2/files/fampp2-7.0.1-libsigc++-2.6.patch b/dev-libs/fampp2/files/fampp2-7.0.1-libsigc++-2.6.patch
new file mode 100644
index 000000000000..6b76a1532cbb
--- /dev/null
+++ b/dev-libs/fampp2/files/fampp2-7.0.1-libsigc++-2.6.patch
@@ -0,0 +1,46 @@
+Remove inclusion of libsigc++ headers obsoleted with version 2.6
+See also: https://bugs.gentoo.org/show_bug.cgi?id=569700
+
+--- a/examples/console_test/famppct.cpp
++++ b/examples/console_test/famppct.cpp
+@@ -30,8 +30,6 @@
+
+ #include <sigc++/sigc++.h>
+ #include <sigc++/slot.h>
+-#include <sigc++/object.h>
+-#include <sigc++/object_slot.h>
+
+ #include <gtk/gtk.h>
+ #include <stdio.h>
+--- a/examples/gtk/famppgtk.cpp
++++ b/examples/gtk/famppgtk.cpp
+@@ -31,8 +31,6 @@
+
+ #include <sigc++/sigc++.h>
+ #include <sigc++/slot.h>
+-#include <sigc++/object.h>
+-#include <sigc++/object_slot.h>
+
+ #include <gtk/gtk.h>
+ #include <stdio.h>
+--- a/src/Fampp2.cpp
++++ b/src/Fampp2.cpp
+@@ -34,8 +34,6 @@
+
+ #include <sigc++/sigc++.h>
+ #include <sigc++/slot.h>
+-#include <sigc++/object.h>
+-#include <sigc++/object_slot.h>
+
+
+ using namespace std;
+--- a/src/FamppEvents.hh
++++ b/src/FamppEvents.hh
+@@ -36,7 +36,6 @@
+
+ #include <fam.h>
+ #include <sigc++/signal.h>
+-#include <sigc++/object.h>
+ #include <SmartPtr.h>
+ #include <Singleton.h>
+ #include <Factory.h>
diff --git a/dev-libs/fampp2/metadata.xml b/dev-libs/fampp2/metadata.xml
new file mode 100644
index 000000000000..37d3ef415f8a
--- /dev/null
+++ b/dev-libs/fampp2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cpp@gentoo.org</email>
+ <name>Gentoo C++ Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">fampp</remote-id>
+ </upstream>
+</pkgmetadata>