summaryrefslogtreecommitdiff
path: root/dev-libs/folks/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-libs/folks/files
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-libs/folks/files')
-rw-r--r--dev-libs/folks/files/0.12.1-meson-0.53-compat.patch47
-rw-r--r--dev-libs/folks/files/0.12.1-meson-0.53-compat2.patch31
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-libs/folks/files/0.12.1-meson-0.53-compat.patch b/dev-libs/folks/files/0.12.1-meson-0.53-compat.patch
new file mode 100644
index 000000000000..56f9543ba40a
--- /dev/null
+++ b/dev-libs/folks/files/0.12.1-meson-0.53-compat.patch
@@ -0,0 +1,47 @@
+From 1853567d79024c6ce960d9dc187cff8aaf9a37ce Mon Sep 17 00:00:00 2001
+From: Niels De Graef <nielsdegraef@gmail.com>
+Date: Mon, 3 Feb 2020 08:57:52 +0100
+Subject: [PATCH] meson: Use python.dependency() correctly
+
+From https://github.com/mesonbuild/meson/issues/6470:
+
+> So, to further clarify, passing an argument to
+> py_installation.dependency() should be an error, since this method
+> will only ever return a python dependency (for embedding python
+> itself, etc.) and not dbusmock or anything else.
+
+Fixxes https://gitlab.gnome.org/GNOME/folks/issues/119
+---
+ meson.build | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index d5115e28..f3644457 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1,7 +1,7 @@
+ project('folks', [ 'vala', 'c' ],
+ version: '0.13.2',
+ license: 'LGPL2.1+',
+- meson_version: '>= 0.49',
++ meson_version: '>= 0.51',
+ )
+
+ gnome = import('gnome')
+@@ -132,8 +132,11 @@ if bluez_backend_enabled
+ libebook_dep = dependency('libebook-1.2', version: '>=' + min_eds_version)
+ # Needed for the BlueZ tests
+ pymod = import('python')
+- py_installation = pymod.find_installation('python3')
+- python_dbusmock = py_installation.dependency('dbusmock')
++ py_installation = pymod.find_installation('python3',
++ modules: [
++ 'dbusmock',
++ ],
++ )
+ endif
+
+ if import_tool_enabled
+--
+2.20.1
+
diff --git a/dev-libs/folks/files/0.12.1-meson-0.53-compat2.patch b/dev-libs/folks/files/0.12.1-meson-0.53-compat2.patch
new file mode 100644
index 000000000000..40c3ca601f05
--- /dev/null
+++ b/dev-libs/folks/files/0.12.1-meson-0.53-compat2.patch
@@ -0,0 +1,31 @@
+From f8a59fb6bf12be06595c94d0b00afed4e1d2f1ee Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 23 Feb 2020 19:28:51 +0200
+Subject: [PATCH] meson: Conditionalize dbusmock check to tests being built
+
+---
+ meson.build | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/meson.build b/meson.build
+index 74320634..64f28d2b 100644
+--- a/meson.build
++++ b/meson.build
+@@ -131,12 +131,14 @@ endif
+ if bluez_backend_enabled
+ libebook_dep = dependency('libebook-1.2', version: '>=' + min_eds_version)
+ # Needed for the BlueZ tests
++ if get_option('test')
+ pymod = import('python')
+ py_installation = pymod.find_installation('python3',
+ modules: [
+ 'dbusmock',
+ ],
+ )
++ endif
+ endif
+
+ if import_tool_enabled
+--
+2.20.1
+