summaryrefslogtreecommitdiff
path: root/dev-libs/gjs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-23 09:44:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-23 09:44:00 +0000
commit8d15cb8238a384acdb70250a0cd213f2ab5f0ab6 (patch)
tree547dd4d959be6b14e702d37e94063dc2104319a5 /dev-libs/gjs
parent71fb24e4cc15fe73651423df81c5e6a79fa8c142 (diff)
gentoo auto-resync : 23:02:2023 - 09:44:00
Diffstat (limited to 'dev-libs/gjs')
-rw-r--r--dev-libs/gjs/Manifest2
-rw-r--r--dev-libs/gjs/gjs-1.74.2.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index ff24c9b0a4db..36dd96efbd14 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1,3 +1,5 @@
DIST gjs-1.74.1.tar.xz 638536 BLAKE2B 375abcaa20a538cfa271f7dcf6f3715e4324ff5a4a9482ce0dd7f78213598a715ebc034f701fe458876f841f72802db4ae2aabf0abc04dc4ac5bb39c917741fd SHA512 346667accb589df0e6a045e30782017eab928115f263d36d521b61b0af38fd268bc518b8ab5ec78e5d25e0194b744a2ee59e65668da679e138b2122858ce0614
+DIST gjs-1.74.2.tar.xz 639012 BLAKE2B 12f6f60b801d96a4cff260a0abc5da96c30a5b77d69d31b646b16db20a586761b36b2601c8da8ab7b313c96b8fb2319ed65cb53f3f3ca2d3d255648ceccdbc7c SHA512 738176aabcc8d0147cf77b7af3271c93ca4e8a473b2d35722b4cf9a15dcdc9f87962a29dd949607d947256df9ffcfd499d7189b6eff7ac416bbad594a2bc8ea9
EBUILD gjs-1.74.1.ebuild 1960 BLAKE2B cc9f89f86583adacec4aee0d6d74696ff81a65356f8b455964c27d1910af46ea2365c8d4cc6586be739048a206447538476feccd324be373d47f8a8a22d65cb1 SHA512 304297e1c12d5dc1b86e09aa78ccd00fbf1a8137e2802e1852c0998b4aeef6f56adc92ee65e4002f6bbb0b2a6a567c8658690600d8705dfaeb1c100751a0d1c2
+EBUILD gjs-1.74.2.ebuild 1966 BLAKE2B 2c2c4f2944ee02788e8b27d58b2e5c47ed7b3eed63cc4ff874ed9d2888215481b94b07a10025bd431925d1d245794c2f3e931e63e2acd4ab12f2cf83705bdf41 SHA512 a9a41000396bae156d79ed459b92f7db62ce4ed5b598385919854f4bbc5fd78894746c8cbbd4fc095b20dd2ac889fb96f9fe748e543e06a557dbe336920d408e
MISC metadata.xml 473 BLAKE2B 0d57ec402b3daaa00af170335374e711150ecccd019aea100484079a055015f36119c4564ae2d95e82e4ac8d6de6d84b83379aedfdcbfb7aaabaa752b51d8203 SHA512 a4f99ef450b30c381845a774865b4e82b2a554cc7f0a2edba7002096563943b58b290f704210cc00ca0508cf6e81a11be2fa0c6402117d2b05f0e4eb2e03a0c2
diff --git a/dev-libs/gjs/gjs-1.74.2.ebuild b/dev-libs/gjs/gjs-1.74.2.ebuild
new file mode 100644
index 000000000000..3c494fc4f0f8
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.74.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gnome.org meson virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gjs https://gitlab.gnome.org/GNOME/gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples readline sysprof test"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ dev-libs/libffi:=
+ >=dev-libs/gobject-introspection-1.66.1:=
+ >=dev-lang/spidermonkey-102.2.0:102
+ cairo? ( x11-libs/cairo[X,glib] )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ >=x11-libs/gtk+-3.20:3[introspection]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ -Db_pch=True # TODO this has to go
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}