summaryrefslogtreecommitdiff
path: root/dev-libs/gnulib/gnulib-2019.03.17.09.24.57.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-libs/gnulib/gnulib-2019.03.17.09.24.57.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-libs/gnulib/gnulib-2019.03.17.09.24.57.ebuild')
-rw-r--r--dev-libs/gnulib/gnulib-2019.03.17.09.24.57.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/gnulib/gnulib-2019.03.17.09.24.57.ebuild b/dev-libs/gnulib/gnulib-2019.03.17.09.24.57.ebuild
new file mode 100644
index 000000000000..131a859af492
--- /dev/null
+++ b/dev-libs/gnulib/gnulib-2019.03.17.09.24.57.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GIT_TAG="b451121ab45497e78cb6f612c8673a9705193391"
+
+DESCRIPTION="Library of common routines intended to be shared"
+HOMEPAGE="https://www.gnu.org/software/gnulib"
+SRC_URI="https://git.savannah.gnu.org/cgit/${PN}.git/snapshot/${PN}-${GIT_TAG}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc-aix ~x86-fbsd ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+S="${WORKDIR}/${PN}-${GIT_TAG}"
+
+src_compile() {
+ if use doc; then
+ emake -C doc info html
+ fi
+}
+
+src_install() {
+ dodoc README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins -r build-aux
+ doins -r doc
+ doins -r lib
+ doins -r m4
+ doins -r modules
+ doins -r tests
+ doins -r top
+
+ # install the real script
+ exeinto /usr/share/${PN}
+ doexe gnulib-tool
+
+ # create and install the wrapper
+ dosym ../share/${PN}/gnulib-tool /usr/bin/gnulib-tool
+}