summaryrefslogtreecommitdiff
path: root/dev-libs/gom
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/gom
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/gom')
-rw-r--r--dev-libs/gom/Manifest3
-rw-r--r--dev-libs/gom/gom-0.3.2.ebuild76
-rw-r--r--dev-libs/gom/metadata.xml8
3 files changed, 87 insertions, 0 deletions
diff --git a/dev-libs/gom/Manifest b/dev-libs/gom/Manifest
new file mode 100644
index 000000000000..9825434bdbac
--- /dev/null
+++ b/dev-libs/gom/Manifest
@@ -0,0 +1,3 @@
+DIST gom-0.3.2.tar.xz 410300 BLAKE2B c0c79c1c3f8a28a0ee992fa4c316538eb87ec26c77def353e8b2038e32f30f9daed433c6d6f6c81069e05e46a980f7d944c955182d973d42f3bd84a341c5a34d SHA512 a7bfb263e5ff6f89768d8fcbdcc949d4ec9b82ecbb80952becd357a3d5781a60e52a327e865e39e46d542b2a2c5e5c861e5302d7ae3c3a2258d3c3f698263675
+EBUILD gom-0.3.2.ebuild 1549 BLAKE2B 51c0dd92ab9fc1da878880258fa1f9bf5195d610c493bf65e55e2a600afcd4bc64b4850594d85c8faf7a82e84caf2cd4761a3b58ec7c37af7c923682d8576a0c SHA512 697886b671e63d10bc03ee4d7c91a73eb3ad27985d418643212b8367d77821a7609fa19c4ea0e267e8f8fe2ee6eb9dbb8a1fa1c5d362f977d2c0e931b3250dca
+MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-libs/gom/gom-0.3.2.ebuild b/dev-libs/gom/gom-0.3.2.ebuild
new file mode 100644
index 000000000000..c69949bbf5ec
--- /dev/null
+++ b/dev-libs/gom/gom-0.3.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="GObject to SQLite object mapper library"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gom"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="+introspection python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} introspection )"
+
+RDEPEND="
+ >=dev-db/sqlite-3.7:3
+ >=dev-libs/glib-2.36:2
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-3.16:3[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-libs/gdk-pixbuf:2
+"
+# TODO: make gdk-pixbuf properly optional with USE=test
+
+pkg_setup() {
+ use python && python_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ use python && python_copy_sources
+}
+
+src_configure() {
+ # glibtest is a relic from AM_PATH_GLIB macro
+ local myconf=(
+ --disable-static
+ --disable-glibtest
+ )
+
+ gnome2_src_configure \
+ ${myconf[@]} \
+ --disable-python \
+ $(use_enable introspection)
+
+ if use python ; then
+ python_foreach_impl run_in_build_dir \
+ gnome2_src_configure \
+ ${myconf[@]} \
+ --enable-python
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use python ; then
+ docinto examples
+ dodoc examples/*.py
+
+ python_foreach_impl run_in_build_dir \
+ emake DESTDIR="${D}" install-overridesPYTHON
+ fi
+}
diff --git a/dev-libs/gom/metadata.xml b/dev-libs/gom/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/dev-libs/gom/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>