summaryrefslogtreecommitdiff
path: root/dev-libs/hiredis/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-23 08:58:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-23 08:58:35 +0100
commit955b5fcaf4acc77c39a1f145d7c56e99f13083a7 (patch)
tree1141703ebc6ca24ff935b991e261d716a5d98243 /dev-libs/hiredis/files
parent24c53d42e0294f4f6e36fbb051891af86c9ae503 (diff)
gentoo auto-resync : 23:05:2023 - 08:58:35
Diffstat (limited to 'dev-libs/hiredis/files')
-rw-r--r--dev-libs/hiredis/files/hiredis-0.13.3-disable-network-tests.patch36
-rw-r--r--dev-libs/hiredis/files/hiredis-0.14.1-honor-AR.patch11
2 files changed, 0 insertions, 47 deletions
diff --git a/dev-libs/hiredis/files/hiredis-0.13.3-disable-network-tests.patch b/dev-libs/hiredis/files/hiredis-0.13.3-disable-network-tests.patch
deleted file mode 100644
index 000e2537b5a0..000000000000
--- a/dev-libs/hiredis/files/hiredis-0.13.3-disable-network-tests.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git test.c test.c
-index 8fde554..89ed6a0 100644
---- a/test.c
-+++ b/test.c
-@@ -343,6 +343,7 @@ static void test_free_null(void) {
- static void test_blocking_connection_errors(void) {
- redisContext *c;
-
-+#if 0
- test("Returns error when host cannot be resolved: ");
- c = redisConnect((char*)"idontexist.test", 6379);
- test_cond(c->err == REDIS_ERR_OTHER &&
-@@ -353,6 +354,7 @@ static void test_blocking_connection_errors(void) {
- strcmp(c->errstr,"Temporary failure in name resolution") == 0 ||
- strcmp(c->errstr,"no address associated with name") == 0));
- redisFree(c);
-+#endif
-
- test("Returns error when the port is not open: ");
- c = redisConnect((char*)"localhost", 1);
-@@ -773,6 +775,7 @@ int main(int argc, char **argv) {
- test_blocking_connection_errors();
- test_free_null();
-
-+#if 0
- printf("\nTesting against TCP connection (%s:%d):\n", cfg.tcp.host, cfg.tcp.port);
- cfg.type = CONN_TCP;
- test_blocking_connection(cfg);
-@@ -781,6 +784,7 @@ int main(int argc, char **argv) {
- test_invalid_timeout_errors(cfg);
- test_append_formatted_commands(cfg);
- if (throughput) test_throughput(cfg);
-+#endif
-
- printf("\nTesting against Unix socket connection (%s):\n", cfg.unix.path);
- cfg.type = CONN_UNIX;
diff --git a/dev-libs/hiredis/files/hiredis-0.14.1-honor-AR.patch b/dev-libs/hiredis/files/hiredis-0.14.1-honor-AR.patch
deleted file mode 100644
index 0bfcf0988e81..000000000000
--- a/dev-libs/hiredis/files/hiredis-0.14.1-honor-AR.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -51,7 +51,7 @@ DYLIB_MAJOR_NAME=$(LIBNAME).$(DYLIBSUFFIX).$(HIREDIS_MAJOR)
- DYLIBNAME=$(LIBNAME).$(DYLIBSUFFIX)
- DYLIB_MAKE_CMD=$(CC) -shared -Wl,-soname,$(DYLIB_MINOR_NAME) -o $(DYLIBNAME) $(LDFLAGS)
- STLIBNAME=$(LIBNAME).$(STLIBSUFFIX)
--STLIB_MAKE_CMD=ar rcs $(STLIBNAME)
-+STLIB_MAKE_CMD=$(AR) rcs $(STLIBNAME)
-
- # Platform-specific overrides
- uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')