summaryrefslogtreecommitdiff
path: root/dev-libs/icinga-php-library/icinga-php-library-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-01 21:08:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-01 21:08:07 +0000
commitc37d894982b59595356319a2b4655fed277097ae (patch)
treeca83d38d2302991de53be516dfae53cf09dab271 /dev-libs/icinga-php-library/icinga-php-library-0.10.0.ebuild
parentdb16929598ac333b179fdfead630dbdfa68840a5 (diff)
gentoo auto-resync : 01:11:2022 - 21:08:07
Diffstat (limited to 'dev-libs/icinga-php-library/icinga-php-library-0.10.0.ebuild')
-rw-r--r--dev-libs/icinga-php-library/icinga-php-library-0.10.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/icinga-php-library/icinga-php-library-0.10.0.ebuild b/dev-libs/icinga-php-library/icinga-php-library-0.10.0.ebuild
new file mode 100644
index 000000000000..c2b93055e450
--- /dev/null
+++ b/dev-libs/icinga-php-library/icinga-php-library-0.10.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Icinga PHP libraries for Icinga Web 2"
+HOMEPAGE="https://github.com/Icinga/icinga-php-library"
+MY_GITHUB_AUTHOR="Icinga"
+SRC_URI="https://github.com/${MY_GITHUB_AUTHOR}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-lang/php:*"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ insinto "/usr/share/icinga-php/ipl"
+ cd "${S}"
+ doins -r *
+}