summaryrefslogtreecommitdiff
path: root/dev-libs/icu-le-hb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-12 03:02:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-12 03:02:41 +0000
commit51be8f45b17e3da3ac48eca6b16b703bb58fda76 (patch)
treebc6f18bc4913276cff3f8c2f2ec357f9026c602c /dev-libs/icu-le-hb
parent0ab98a20dbfb8c64ab93e02280abb4ff18652ae0 (diff)
gentoo auto-resync : 12:11:2024 - 03:02:41
Diffstat (limited to 'dev-libs/icu-le-hb')
-rw-r--r--dev-libs/icu-le-hb/Manifest2
-rw-r--r--dev-libs/icu-le-hb/icu-le-hb-2.0.0.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/icu-le-hb/Manifest b/dev-libs/icu-le-hb/Manifest
index f060e14ab9d0..dda2b5be0d57 100644
--- a/dev-libs/icu-le-hb/Manifest
+++ b/dev-libs/icu-le-hb/Manifest
@@ -1,3 +1,5 @@
DIST icu-le-hb-1.2.3.tar.gz 45191 BLAKE2B 14ad8592a27ff8673d9609a689bedf5094c127bb9cb638a1e65c1fcb6e22e8c488f89e55af5578cd4961a34feafffd5df9cdedb20dfc7edcc4d6f63aec1eff0f SHA512 c1450e28c1984a409cacc2b675ab91fa0e80edfbbfb201913cb83e435fd30f3a3ad78ca32f8cf092c5f056f2812b899ceb4471b36ef975faf5be892d305a1efd
+DIST icu-le-hb-2.0.0.tar.gz 421450 BLAKE2B 20b72590ff5b968754ab369f57770c449fa68e001c9211987adf708447a6ee956266b1fa64049651b2b132afcb98f9c456d3549e48db5d8d40faa0ec90cd801d SHA512 aa8d822ef3c471a8e4325a8f4bc01011e096b7fcc0c7cbab3849f91bda6b802397c831e8db34525ebaa2b14e2a007a5728af92e75f0605d944973984c2ceec28
EBUILD icu-le-hb-1.2.3.ebuild 924 BLAKE2B 2970f4f81d7a76a0d70f6046618bbd9d8305f09d12e47c0f222e2192dd76cc7472d662e6d6551159e9f8e35aa2a45e41c0d398b489ced24639d3c8090582b357 SHA512 449f8ebb25b7259f03b22053ae24e60b8a4959132480121cfc3782bea66a96f7205314ee9c310d214fccb74932b87b6ea772e539c925fa6b33f86dff331effe2
+EBUILD icu-le-hb-2.0.0.ebuild 884 BLAKE2B db49c97d0de65ac1470cc164364edda90642aeba215e35a09088be565e51e2a68c360207e7938ee21951b688b7925f3d26a894b1404e8e611c9f59fe1471df1e SHA512 d388bf27f5821414b11c99b0aa5dcf629aab7aba70259f5f9ac9199108a9f7d4890ec6684816a99b1365fa887a694f0f2f3fda0066c0896a3250b406c13a8263
MISC metadata.xml 347 BLAKE2B 546d769021cbb1aa5c9f7f1c05d2c90297ad28d3af1218e9bd56e0d02cc2561b5ccba7f1cd29cbc72c942e41633671a8efc2e48ef4edf6554e81230f08617b56 SHA512 fa2a772deeb8249f17c85df71f50977ac50aa0fbce4c93cd6982e724bf74e1dd768edb6ec503507daed56d216befae024c2997e0c1d71800071e5d03e991fe6b
diff --git a/dev-libs/icu-le-hb/icu-le-hb-2.0.0.ebuild b/dev-libs/icu-le-hb/icu-le-hb-2.0.0.ebuild
new file mode 100644
index 000000000000..ac7bf9a5f380
--- /dev/null
+++ b/dev-libs/icu-le-hb/icu-le-hb-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="ICU Layout Engine API on top of HarfBuzz shaping library"
+HOMEPAGE="https://github.com/harfbuzz/harfbuzz https://github.com/harfbuzz/icu-le-hb"
+SRC_URI="https://github.com/harfbuzz/icu-le-hb/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="icu"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+# dev-libs/icu is not linked into icu-le-hb but the latter still needs
+# to be rebuilt on dev-libs/icu upgrades (see bug #621786).
+RDEPEND="
+ dev-libs/icu:=[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.0.0:=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "*.la" -delete || die
+}