summaryrefslogtreecommitdiff
path: root/dev-libs/imath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-03 15:31:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-03 15:31:48 +0100
commitc1503bdaa031111d22d91db2f41dad440fb148e8 (patch)
tree9760e4735d0c80c6b4679eb9b1369b33dec5e668 /dev-libs/imath
parent9f322d80b846d0000268f94422b74c28979e4adf (diff)
gentoo auto-resync : 03:06:2023 - 15:31:48
Diffstat (limited to 'dev-libs/imath')
-rw-r--r--dev-libs/imath/Manifest2
-rw-r--r--dev-libs/imath/imath-3.1.6.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/imath/Manifest b/dev-libs/imath/Manifest
index 177d20f30388..164cbbcb796c 100644
--- a/dev-libs/imath/Manifest
+++ b/dev-libs/imath/Manifest
@@ -1,3 +1,5 @@
+DIST imath-3.1.6.tar.gz 573255 BLAKE2B c4d5a785a2aed9c5b9b1441ab016a5cf47abeb1d44c0625f0654e8c4d1e47dddddd62c61f83fd7b160beae8aaf5db9350d2a3bc43754e795fe75b10c4836a1b8 SHA512 c099a291ed7fd7702a7609575f2f3d2ed7f95256c23c2180e2ef1f76ceb07734365f57da5244b1d6cec81ca9859864eb4c9236df02a64aa783af6639a3b59acd
DIST imath-3.1.7.tar.gz 583049 BLAKE2B 54619339f349a944e1d72fcea4438d7bd2ef6c9655ba0e16ac608934a8df30c97a2f3cf5c75adaeb8a6fe6bf19ec3240c11439550b452571d0a8cbf75d6bd83e SHA512 e298454cb845cadde28f7881fdaa4739c3942f941278a07ec912459ac376c2ee7858cb3b2d2047b9afb4d4dacae7a8a52ffef4c104f8499b4e0a1f0ed46cc0f0
+EBUILD imath-3.1.6.ebuild 1800 BLAKE2B faec63b46c4f95ae667df6a7fa78744e55d93d01a2b55c3733dcae42f03d002351933a41ff64dbdae673a533c2bc266518dad1441b59ad4ceb042063677ed523 SHA512 2bffa1028a30d340dc8db9585ad8dae3c830c834799d92ba4285ee0a2db52c6fb4ce0234a0f094988c3311340134e08ce1cb6960642faf186c71777ce1de1c4d
EBUILD imath-3.1.7.ebuild 1851 BLAKE2B 25b2d3be469be0463756c1753985771e4e698742de04df6e968b5afbf1c4eec6ded223521729c743c9cd051d177f2eae09dd34bc8c2a3a9923ea13df70a82d2e SHA512 9fe18533623317fdd52cd75e4ec9794247aacf443a050037bd4fe9f218f9ce8130f06dd0ae21309865cd1459e069134889b8d6903c9eff257212b14a5e1c1da1
MISC metadata.xml 820 BLAKE2B f035962970166d4c636e8b98b9301e31fbc27aecb7059289a7581958619b85c7f60551d56175637d373363a41c7349c8c78ec31348590826313bdca94aec6727 SHA512 9dbff2f917f1705a611680c46f73a0ad372f27f6b5c236f691f16b6c41a51cb3d8712c4bceddb5469742f4952385e2a2b07377c4c216736810562ae89c5c52f4
diff --git a/dev-libs/imath/imath-3.1.6.ebuild b/dev-libs/imath/imath-3.1.6.ebuild
new file mode 100644
index 000000000000..140156298dbb
--- /dev/null
+++ b/dev-libs/imath/imath-3.1.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cmake python-single-r1
+
+MY_PN="${PN^}"
+
+DESCRIPTION="Imath basic math package"
+HOMEPAGE="https://imath.readthedocs.io"
+SRC_URI="https://github.com/AcademySoftwareFoundation/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+# re-keywording needed for (according to ilmbase keywords): ~x64-macos ~x86-solaris
+KEYWORDS="amd64 ~arm arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="3/29"
+IUSE="doc large-stack python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+# blocker due to file collision #803347
+RDEPEND="
+ !dev-libs/imath:0
+ !media-libs/ilmbase
+ sys-libs/zlib
+ python? (
+ !dev-python/pyilmbase
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ')
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( $(python_gen_cond_dep 'dev-python/breathe[${PYTHON_USEDEP}]') )
+ python? ( ${PYTHON_DEPS} )
+"
+
+DOCS=( CHANGES.md CONTRIBUTORS.md README.md SECURITY.md docs/PortingGuide2-3.md )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOCS=$(usex doc)
+ -DIMATH_ENABLE_LARGE_STACK=$(usex large-stack)
+ -DIMATH_HALF_USE_LOOKUP_TABLE=ON
+ -DIMATH_INSTALL_PKG_CONFIG=ON
+ -DIMATH_USE_CLANG_TIDY=OFF
+ -DIMATH_USE_NOEXCEPT=ON
+ )
+ if use python; then
+ mycmakeargs+=(
+ -DBoost_NO_BOOST_CMAKE=OFF
+ -DPYTHON=ON
+ -DPython3_EXECUTABLE="${PYTHON}"
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
+ fi
+
+ cmake_src_configure
+}