summaryrefslogtreecommitdiff
path: root/dev-libs/inih/inih-57.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-07 04:15:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-07 04:15:42 +0100
commit0735b7c70f35339a20b45aee2a0a0ad80d118550 (patch)
tree2701d176f865b77b7ebd8ee7fa1445ee04d13533 /dev-libs/inih/inih-57.ebuild
parent37707aeea7000a1e20d52db99ca6a70674ce89f3 (diff)
gentoo auto-resync : 07:07:2023 - 04:15:41
Diffstat (limited to 'dev-libs/inih/inih-57.ebuild')
-rw-r--r--dev-libs/inih/inih-57.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/inih/inih-57.ebuild b/dev-libs/inih/inih-57.ebuild
new file mode 100644
index 000000000000..ba61d2ec922a
--- /dev/null
+++ b/dev-libs/inih/inih-57.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Tests not wired up to meson and don't seem to be intended for downstream use yet
+# e.g. hardcoding gcc, just a shell script
+
+inherit meson
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/inih-r${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DOCS=( README.md )
+
+src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson_src_configure
+}