summaryrefslogtreecommitdiff
path: root/dev-libs/injeqt/injeqt-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/injeqt/injeqt-1.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/injeqt/injeqt-1.2.0.ebuild')
-rw-r--r--dev-libs/injeqt/injeqt-1.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/injeqt/injeqt-1.2.0.ebuild b/dev-libs/injeqt/injeqt-1.2.0.ebuild
new file mode 100644
index 000000000000..6b98e1bd2372
--- /dev/null
+++ b/dev-libs/injeqt/injeqt-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Dependency injection framework for Qt5"
+HOMEPAGE="https://github.com/vogel/injeqt"
+SRC_URI="https://github.com/vogel/injeqt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-qt/qtcore-5.4.2:5
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qttest-5.4.2:5 )
+"
+
+# https://github.com/vogel/injeqt/issues/18
+RESTRICT=test
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_EXAMPLES=ON
+ -DDISABLE_TESTS=$(usex !test)
+ )
+ cmake-utils_src_configure
+}