summaryrefslogtreecommitdiff
path: root/dev-libs/intel-metrics-discovery/intel-metrics-discovery-1.13.176.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-16 12:11:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-16 12:11:35 +0100
commitb66ecfb4dc09ba76e37787df2f7df1a78c3c1cc9 (patch)
tree884bce771a1bba8b311dfffbde4acdad07bf2c54 /dev-libs/intel-metrics-discovery/intel-metrics-discovery-1.13.176.ebuild
parent08e318096831eb3aae369910ba75e27f59367e2f (diff)
gentoo auto-resync : 16:09:2024 - 12:11:35
Diffstat (limited to 'dev-libs/intel-metrics-discovery/intel-metrics-discovery-1.13.176.ebuild')
-rw-r--r--dev-libs/intel-metrics-discovery/intel-metrics-discovery-1.13.176.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/intel-metrics-discovery/intel-metrics-discovery-1.13.176.ebuild b/dev-libs/intel-metrics-discovery/intel-metrics-discovery-1.13.176.ebuild
new file mode 100644
index 000000000000..1aa1fe8dda1b
--- /dev/null
+++ b/dev-libs/intel-metrics-discovery/intel-metrics-discovery-1.13.176.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake
+
+DESCRIPTION="A user mode library that provides access to GPU performance data"
+HOMEPAGE="https://github.com/intel/metrics-discovery"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${MY_P}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+
+DEPEND="x11-libs/libdrm"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.12.170-revert-definitions.patch" )
+
+src_configure() {
+ local mycmakeargs=( -DLINUX_DISTRO="Gentoo" )
+ cmake_src_configure
+}