summaryrefslogtreecommitdiff
path: root/dev-libs/json-glib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/json-glib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/json-glib')
-rw-r--r--dev-libs/json-glib/Manifest3
-rw-r--r--dev-libs/json-glib/json-glib-1.2.8.ebuild55
-rw-r--r--dev-libs/json-glib/metadata.xml15
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/json-glib/Manifest b/dev-libs/json-glib/Manifest
new file mode 100644
index 000000000000..fd176ec6c89a
--- /dev/null
+++ b/dev-libs/json-glib/Manifest
@@ -0,0 +1,3 @@
+DIST json-glib-1.2.8.tar.xz 604336 BLAKE2B c85b7dcdb8d409afc1c0261e97e271f5be67a4dbc21d1ac2f6ace656106ca437f3330fda90f5add8371118b0c233f2dcd2bb9b6bc20c6452c1f85a44895eb008 SHA512 85d8ad431363b8698d71684927b8aa38749d99ea7236334ec09fd81482489f1ab9cb12dabcbe13f6b6ffd7e5d70ade47a36b511e275915d4aa858af647db90ba
+EBUILD json-glib-1.2.8.ebuild 1412 BLAKE2B 6b259fac66dc2810bcaf401dbf42c27f3acbc3aa9300d4b8e5e762c4f795bc1b2e74f96606307de871c310b3b837a8ace55bb76a5ad3c36fa1544204d17bc65c SHA512 bef69e80ebe43f4e84d6e1a0a0da1285dbb2538d680bbe9c27e4b780ecbf99a9454309cd1c244ccf3736ac7f82ddf6e69c2bd1b27a1b590b8db7d31e71e2614a
+MISC metadata.xml 1168 BLAKE2B f92f6fe2026abedfcd6f51797df84573b33817b10203e0325aa9790cc9c58ea6c9d69724b122dfe3c9b7b2a34cbf15e5e245c8aa93a1f8802757ac1c2ce61a7d SHA512 9af9dffd8e1d56c9dad5a0c53bdf16f5d54261c8c121cbc9644865340b84101a0bfcafc393bfe0d6b31024b16f1bbe9f9305286bc56a2df20a08984f55cb91e1
diff --git a/dev-libs/json-glib/json-glib-1.2.8.ebuild b/dev-libs/json-glib/json-glib-1.2.8.ebuild
new file mode 100644
index 000000000000..2181414d8a04
--- /dev/null
+++ b/dev-libs/json-glib/json-glib-1.2.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="Library providing GLib serialization and deserialization for the JSON format"
+HOMEPAGE="https://wiki.gnome.org/Projects/JsonGlib"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.37.6:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+DEPEND="${RDEPEND}
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.20
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ # Do not touch CFLAGS with --enable-debug=yes
+ sed -e 's/CFLAGS -g/CFLAGS/' -i "${S}"/configure || die
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ # Coverage support is useless, and causes runtime problems
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --enable-man \
+ --disable-gcov \
+ $(usex debug --enable-debug=yes --enable-debug=minimum) \
+ $(multilib_native_use_enable introspection) \
+ --with-xml-catalog="${EPREFIX}"/etc/xml/catalog
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_compile() {
+ gnome2_src_compile
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/dev-libs/json-glib/metadata.xml b/dev-libs/json-glib/metadata.xml
new file mode 100644
index 000000000000..0aa1782a946f
--- /dev/null
+++ b/dev-libs/json-glib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <longdescription>JSON-GLib is a library providing serialization and deserialization support for the JavaScript Object Notation (JSON) format described by RFC 4627. Many high-level languages already provide native modules for parsing, generating and manipulating JSON data streams. JSON-GLib is a C library based on GLib and released under the terms of the GNU Lesser General Public License version 2.1. It provides a parser and a generator GObject classes and various wrappers for the complex data types employed by JSON, such as arrays and objects.
+
+JSON-GLib uses GLib native data types and the generic value container GValue for ease of development. It also provides integration with the GObject classes for direct serialization into, and deserialization from, JSON data streams.</longdescription>
+</pkgmetadata>