summaryrefslogtreecommitdiff
path: root/dev-libs/judy/judy-1.0.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-libs/judy/judy-1.0.5-r2.ebuild
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-libs/judy/judy-1.0.5-r2.ebuild')
-rw-r--r--dev-libs/judy/judy-1.0.5-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/judy/judy-1.0.5-r2.ebuild b/dev-libs/judy/judy-1.0.5-r2.ebuild
new file mode 100644
index 000000000000..e118223b34de
--- /dev/null
+++ b/dev-libs/judy/judy-1.0.5-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools ltprune multilib-minimal
+
+DESCRIPTION="A C library that implements a dynamic array"
+HOMEPAGE="http://judy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/judy/Judy-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static-libs"
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}/${P}-parallel-make.patch"
+ eapply "${FILESDIR}/${P}-gcc49.patch"
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+ eapply_user
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${BUILD_DIR} econf $(use_enable static-libs static)
+}
+
+multilib_src_install_all(){
+ einstalldocs
+ prune_libtool_files
+}