summaryrefslogtreecommitdiff
path: root/dev-libs/libaio/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-libs/libaio/files
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-libs/libaio/files')
-rw-r--r--dev-libs/libaio/files/libaio-0.3.111-optional-werror.patch30
-rw-r--r--dev-libs/libaio/files/libaio-0.3.112-cppflags.patch25
-rw-r--r--dev-libs/libaio/files/libaio-0.3.112-install.patch60
3 files changed, 115 insertions, 0 deletions
diff --git a/dev-libs/libaio/files/libaio-0.3.111-optional-werror.patch b/dev-libs/libaio/files/libaio-0.3.111-optional-werror.patch
new file mode 100644
index 000000000000..5b6f91e56d98
--- /dev/null
+++ b/dev-libs/libaio/files/libaio-0.3.111-optional-werror.patch
@@ -0,0 +1,30 @@
+From ebe62b178f3e5fcde8a311e64aaffe62099204a5 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 21 Apr 2019 12:44:26 +0200
+Subject: [PATCH] make -Werror into an optional flag
+
+This lets distros disable the flag as random errors might come up with
+different compiler flags and older/newer toolchain versions.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ harness/Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/harness/Makefile b/harness/Makefile
+index f477737..a155c4b 100644
+--- a/harness/Makefile
++++ b/harness/Makefile
+@@ -6,7 +6,8 @@ PROGS:=$(PARTPROGS) $(EXTRAPROGS)
+ HARNESS_SRCS:=main.c
+ # io_queue.c
+
+-CFLAGS+=-Wall -Werror -I../src -g -O2 -DPAGE_SIZE=$(shell getconf PAGESIZE)
++CFLAGS_WERROR?=-Werror
++CFLAGS+=-Wall $(CFLAGS_WERROR) -I../src -g -O2 -DPAGE_SIZE=$(shell getconf PAGESIZE)
+ #-lpthread -lrt
+
+ all: $(PROGS)
+--
+2.21.0
+
diff --git a/dev-libs/libaio/files/libaio-0.3.112-cppflags.patch b/dev-libs/libaio/files/libaio-0.3.112-cppflags.patch
new file mode 100644
index 000000000000..2f1ba4b7aec1
--- /dev/null
+++ b/dev-libs/libaio/files/libaio-0.3.112-cppflags.patch
@@ -0,0 +1,25 @@
+From 1df69d571c5b764c42ba17970707cc29d2394a25 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 21 Apr 2019 13:04:24 +0200
+Subject: [PATCH 2/2] respect env CPPFLAGS
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ src/Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/Makefile b/src/Makefile
+index 66534b9..44bbef8 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -5,6 +5,7 @@ usrlibdir=$(libdir)
+
+ CFLAGS ?= -g -fomit-frame-pointer -O2
+ CFLAGS += -Wall -I. -fPIC
++CFLAGS += $(CPPFLAGS)
+ SO_CFLAGS=-shared $(CFLAGS)
+ L_CFLAGS=$(CFLAGS)
+ LINK_FLAGS=
+--
+2.21.0
+
diff --git a/dev-libs/libaio/files/libaio-0.3.112-install.patch b/dev-libs/libaio/files/libaio-0.3.112-install.patch
new file mode 100644
index 000000000000..d1b1873b501a
--- /dev/null
+++ b/dev-libs/libaio/files/libaio-0.3.112-install.patch
@@ -0,0 +1,60 @@
+From f8fbbc9733035c96ffb085726bf24d15502e1095 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 21 Apr 2019 13:02:16 +0200
+Subject: [PATCH 1/2] fix up install paths
+
+This is similar to the Fedora patch, but this uses more common conventions
+like "DESTDIR" instead of "destdir".
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Makefile | 2 +-
+ src/Makefile | 11 ++++++-----
+ 2 files changed, 7 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index c1fb831..e9dbdb0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -14,7 +14,7 @@ all:
+ @$(MAKE) -C src
+
+ install:
+- @$(MAKE) -C src install prefix=$(DESTDIR)$(prefix) includedir=$(DESTDIR)$(includedir) libdir=$(DESTDIR)$(libdir)
++ @$(MAKE) -C src install prefix=$(prefix) includedir=$(includedir) libdir=$(libdir)
+
+ check:
+ @$(MAKE) -C harness check
+diff --git a/src/Makefile b/src/Makefile
+index 37ae219..66534b9 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -1,6 +1,7 @@
+ prefix=/usr
+ includedir=$(prefix)/include
+ libdir=$(prefix)/lib
++usrlibdir=$(libdir)
+
+ CFLAGS ?= -g -fomit-frame-pointer -O2
+ CFLAGS += -Wall -I. -fPIC
+@@ -58,12 +59,12 @@ $(libname): $(libaio_sobjs) libaio.map
+ $(CC) $(SO_CFLAGS) -Wl,--version-script=libaio.map -Wl,-soname=$(soname) -o $@ $(libaio_sobjs) $(LINK_FLAGS)
+
+ install: $(all_targets)
+- install -D -m 644 libaio.h $(includedir)/libaio.h
+- install -D -m 644 libaio.a $(libdir)/libaio.a
++ install -D -m 644 libaio.h $(DESTDIR)$(includedir)/libaio.h
++ install -D -m 644 libaio.a $(DESTDIR)$(usrlibdir)/libaio.a
+ ifeq ($(ENABLE_SHARED),1)
+- install -D -m 755 $(libname) $(libdir)/$(libname)
+- ln -sf $(libname) $(libdir)/$(soname)
+- ln -sf $(libname) $(libdir)/libaio.so
++ install -D -m 755 $(libname) $(DESTDIR)$(libdir)/$(libname)
++ ln -sf $(libname) $(DESTDIR)$(usrlibdir)/$(soname)
++ ln -sf $(libname) $(DESTDIR)$(usrlibdir)/libaio.so
+ endif
+
+ $(libaio_objs): libaio.h
+--
+2.21.0
+