summaryrefslogtreecommitdiff
path: root/dev-libs/libarcus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libarcus
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libarcus')
-rw-r--r--dev-libs/libarcus/Manifest3
-rw-r--r--dev-libs/libarcus/libarcus-3.3.0.ebuild42
-rw-r--r--dev-libs/libarcus/metadata.xml30
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-libs/libarcus/Manifest b/dev-libs/libarcus/Manifest
new file mode 100644
index 000000000000..da13ec413200
--- /dev/null
+++ b/dev-libs/libarcus/Manifest
@@ -0,0 +1,3 @@
+DIST libarcus-3.3.0.tar.gz 29695 BLAKE2B a63ca06133cf7db556fe82cc7ea060badd7838d697822d64e09c52aaa81a8509bfa6010037004593da3b1e66dde510767a992524f8e1719e614932b88b9393fe SHA512 a911fb5784ceb835ba2c175ce42cc10544bdd0834e987d8ac1be2517293f00e596f94910d8bf5f37f61e63246ba6e78d28a23bc061809e70b1bb6ad1a21107c9
+EBUILD libarcus-3.3.0.ebuild 1085 BLAKE2B 9d15a9454356b09eb8f05a4548bf49ee8d9ce710d47ec89baf5d11cfbc8b1c9dcc2db503e491f3558eb9da4e5456e823a51fbf7aec33d7ef68b6906d572d5d99 SHA512 95709735d9f791bb344442964ca877d480060ea8fe13c82941a30fbcdc84da2ab9c055570f37f6dd757c5347dd1451759558c73f8a02f7fd22215cd5c9f54a77
+MISC metadata.xml 860 BLAKE2B 9375bca572d46d985fbbf11b222728cdaba22c2fde64e1b4a057d2920b9845bf442bb35ce0b2b1e78fc949cd687604f9f89d5b5665e3cee7afe5b69f09f5ed2b SHA512 9dbfeff3c641642edfd27fbbd27d2ef5810833e4cb3ae5b949c1a20c27377ac70364010fc9fbc759f456e93f294af62f3c08c59bb0585a3ca01f5cd157b3b33e
diff --git a/dev-libs/libarcus/libarcus-3.3.0.ebuild b/dev-libs/libarcus/libarcus-3.3.0.ebuild
new file mode 100644
index 000000000000..d0e49ef66b98
--- /dev/null
+++ b/dev-libs/libarcus/libarcus-3.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit cmake-utils python-single-r1
+
+MY_PN="libArcus"
+
+DESCRIPTION="This library facilitates communication between Cura and its backend"
+HOMEPAGE="https://github.com/Ultimaker/libArcus"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/sip[${PYTHON_USEDEP}]
+ dev-libs/protobuf
+ python? ( dev-python/protobuf-python[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PYTHON=$(usex python ON OFF)
+ -DBUILD_EXAMPLES=$(usex examples ON OFF)
+ -DBUILD_STATIC=$(usex static-libs ON OFF)
+ )
+ use python && mycmakeargs+=( -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/libarcus/metadata.xml b/dev-libs/libarcus/metadata.xml
new file mode 100644
index 000000000000..dce895cd5780
--- /dev/null
+++ b/dev-libs/libarcus/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mathy@vanvoorden.be</email>
+ <name>Mathy Vanvoorden</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>perlovka@gmail.com</email>
+ <name>Michael Perlov</name>
+ </maintainer>
+ <slots>
+ <subslots>soname major version number</subslots>
+ </slots>
+ <upstream>
+ <remote-id type="github">Ultimaker/libArcus</remote-id>
+ </upstream>
+</pkgmetadata>