summaryrefslogtreecommitdiff
path: root/dev-libs/libarcus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-12 18:08:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-12 18:08:24 +0100
commit8a60ccc0bb618fc402bc140a5cee6cf89addec51 (patch)
tree65afd2233c6a32062b2b52a4a901abf4f801c12d /dev-libs/libarcus
parent78f20b3ec2b822f4add309f60998356f403cf879 (diff)
gentoo auto-resync : 12:08:2023 - 18:08:23
Diffstat (limited to 'dev-libs/libarcus')
-rw-r--r--dev-libs/libarcus/Manifest4
-rw-r--r--dev-libs/libarcus/files/libarcus-4.8.0-deprecated-protobuf-calls.patch30
-rw-r--r--dev-libs/libarcus/libarcus-4.13.1.ebuild56
-rw-r--r--dev-libs/libarcus/metadata.xml28
4 files changed, 0 insertions, 118 deletions
diff --git a/dev-libs/libarcus/Manifest b/dev-libs/libarcus/Manifest
deleted file mode 100644
index 9cbcfeb62730..000000000000
--- a/dev-libs/libarcus/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX libarcus-4.8.0-deprecated-protobuf-calls.patch 1395 BLAKE2B 6488f7da07b78df1f18826a62f47cc2a7835ad66f7c5f999a4926caff9bffa8125b39f44cbb4e5849b3283c95898120c2cdc0947c9008869af91db08f0036e55 SHA512 f98cdd0d15d03752cd04466211cdaf2fb0ebb4f9a5aa887c4f9a1df5c32ced18559952f89c4549ea93376d95ec0b1bc51289ce87256804d2fc453686d48b55e5
-DIST libarcus-4.13.1.tar.gz 32077 BLAKE2B 8a75de1ccd0879db817cd67600f83e765e00eed175d73685331ea7f1cde07dabd5c49c9b0f3f039a2a0e6ad7f491fa34de62054494fd9c588e3bb530370b65b7 SHA512 ffb14595f23c47f71082b994eae01471f45e2e9e1ae9a8ad01df577b9445594c30173388beab016a92be9723638ca6e46b5cecddddc6adc97e9d212fc0fa23fa
-EBUILD libarcus-4.13.1.ebuild 1358 BLAKE2B 4796e561f53e0eb4b805a9e8591ac9a4deae3f011a5fab1ab86a3bc4822f41c908b03ee35ab6ea83b9f1acfc8a82b86f3e01b66e7e545ce3d1278c11e034e88d SHA512 f78acb638d5ead193277b2cbc0cc197e71e2ba14807a9c888c9e21d315d7c8df355e02fdd5bd334904d066a0e90711d2c0b0b4abd88dfced05b609333168d2fa
-MISC metadata.xml 1054 BLAKE2B 489d56cbdde162445a89886b966050261bdc5ab27a8bd20d17122d3413eb1a3ec08f12163852dcfe955d9507228e762e5e71ae402806bdb2213eb38b88af07fe SHA512 6faa62e4439e21f7a42638282cb95298bd4e0736595616294572bd5f5a624ca919d0f476fe75b1f5fae59e9f438755e8376f66dc4091a6f70560d0722736d6e8
diff --git a/dev-libs/libarcus/files/libarcus-4.8.0-deprecated-protobuf-calls.patch b/dev-libs/libarcus/files/libarcus-4.8.0-deprecated-protobuf-calls.patch
deleted file mode 100644
index 659885d406e3..000000000000
--- a/dev-libs/libarcus/files/libarcus-4.8.0-deprecated-protobuf-calls.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/src/Socket_p.h
-+++ b/src/Socket_p.h
-@@ -128,9 +128,6 @@
-
- static const int keep_alive_rate = 500; //Number of milliseconds between sending keepalive packets
-
-- // This value determines when protobuf should warn about very large messages.
-- static const int message_size_warning = 400 * 1048576;
--
- // This value determines when protobuf should error out because the message is too large.
- // Due to the way Protobuf is implemented, messages large than 512MiB will cause issues.
- static const int message_size_maximum = 500 * 1048576;
-@@ -362,7 +359,7 @@
- return;
- }
-
-- uint32_t message_size = message->ByteSize();
-+ uint32_t message_size = message->ByteSizeLong();
- if(platform_socket.writeUInt32(message_size) == -1)
- {
- error(ErrorCode::SendFailedError, "Could not send message size");
-@@ -548,7 +545,7 @@
-
- google::protobuf::io::ArrayInputStream array(wire_message->data, wire_message->size);
- google::protobuf::io::CodedInputStream stream(&array);
-- stream.SetTotalBytesLimit(message_size_maximum, message_size_warning);
-+ stream.SetTotalBytesLimit(message_size_maximum);
- if(!message->ParseFromCodedStream(&stream))
- {
- error(ErrorCode::ParseFailedError, "Failed to parse message:" + std::string(wire_message->data));
diff --git a/dev-libs/libarcus/libarcus-4.13.1.ebuild b/dev-libs/libarcus/libarcus-4.13.1.ebuild
deleted file mode 100644
index 77d40e732248..000000000000
--- a/dev-libs/libarcus/libarcus-4.13.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit cmake python-single-r1
-
-MY_PN="libArcus"
-
-DESCRIPTION="This library facilitates communication between Cura and its backend"
-HOMEPAGE="https://github.com/Ultimaker/libArcus"
-SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0/3"
-KEYWORDS="amd64 ~arm64 ~x86"
-IUSE="examples +python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="${PYTHON_DEPS}
- dev-libs/protobuf:=
- $(python_gen_cond_dep '
- <dev-python/sip-5[${PYTHON_USEDEP}]
- python? ( dev-python/protobuf-python[${PYTHON_USEDEP}] )
- ')"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.8.0-deprecated-protobuf-calls.patch
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # Find SIP for current python version, not the latest installed
- sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" \
- CMakeLists.txt cmake/FindSIP.cmake || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_EXAMPLES=$(usex examples ON OFF)
- -DBUILD_PYTHON=$(usex python ON OFF)
- -DBUILD_STATIC=$(usex static-libs ON OFF)
- )
-
- cmake_src_configure
-}
diff --git a/dev-libs/libarcus/metadata.xml b/dev-libs/libarcus/metadata.xml
deleted file mode 100644
index 777a4fbbb00a..000000000000
--- a/dev-libs/libarcus/metadata.xml
+++ /dev/null
@@ -1,28 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>3dprint@gentoo.org</email>
- <name>Gentoo 3D Printer Project</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <maintainer type="person" proxied="yes">
- <email>mathy@vanvoorden.be</email>
- <name>Mathy Vanvoorden</name>
- </maintainer>
- <longdescription>
- This library contains C++ code and Python3 bindings for creating a socket in a thread and using this socket to
- send and receive messages based on the Protocol Buffers library.
- It is designed to facilitate the communication between Cura and its backend and similar code.
- </longdescription>
- <slots>
- <subslots>soname major version number</subslots>
- </slots>
- <upstream>
- <bugs-to>https://github.com/Ultimaker/libArcus/issues</bugs-to>
- <remote-id type="github">Ultimaker/libArcus</remote-id>
- </upstream>
-</pkgmetadata>