summaryrefslogtreecommitdiff
path: root/dev-libs/libassuan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libassuan
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libassuan')
-rw-r--r--dev-libs/libassuan/Manifest5
-rw-r--r--dev-libs/libassuan/libassuan-2.4.3-r1.ebuild44
-rw-r--r--dev-libs/libassuan/metadata.xml19
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/libassuan/Manifest b/dev-libs/libassuan/Manifest
new file mode 100644
index 000000000000..c09b3b581d96
--- /dev/null
+++ b/dev-libs/libassuan/Manifest
@@ -0,0 +1,5 @@
+DIST libassuan-2.4.3.tar.bz2 559867 SHA256 22843a3bdb256f59be49842abf24da76700354293a066d82ade8134bb5aa2b71 SHA512 2b0f58682b408fc58fa0ec2980b36e54ba66701bf504cf6c98ec652af43501bc7c18573bc78c5b83260f5a3bdb0ec8f4e0662bafd9bba3fe7287e77598e8e4c1 WHIRLPOOL fda468446ee6d6884588541867d01d058f073050c892f2a7d2ab433bd62d0d03a9473851eda6b5621bac9a4e0256df5a0bbe5d6375d918de434dbe2b7ffbf709
+EBUILD libassuan-2.4.3-r1.ebuild 1099 SHA256 2baee3cfd0d5950a0948fa239709cebf575067e314bae83c2cf0d04e826a1bab SHA512 a3cab0a03de279a18d49db4bc521dbfd04340f66edddb1cb05ac1dfdf6ab4096d1f082c3115e8cfa281873f2d25f810fdbe514aa083313e66a2c470e0e752db8 WHIRLPOOL 5367b8cc6b228aacd571ce136dc7a7943c48078b6ae71d92e0d57beed1684d6d515fbf3f2b56d121ef8ac93b796239154ecbc417f6d65ab7d0fa957fdee0c474
+MISC ChangeLog 5719 SHA256 a10d35627cbb2307e089400077ccd1e8e069263541d3e4dab314aaff3bdb32ee SHA512 068d74f3480e8857c8eb107e7d05e259d02384af5fe0d696e0b4df509cdad00ed452c104dc91606f9e7703e9825c7f8f2aedd997c30b3df296d7cebe097120ff WHIRLPOOL d5eb28e4467a7904cd456e90952947cc08746aa8475fc9a3efc19e40a163e346e4383b189c029ef8e3f4d4ba11506531f445bd622711f53c7ca878c23c6ef5ec
+MISC ChangeLog-2015 14809 SHA256 e7368362f5ff0828ef8675791cc30c01cb1c988f09894ed31938786b3a593bb8 SHA512 e545672f36630e452b4ee61d602bcf6472dc3182045e3712ca1e99909552ab55d8375bae6273d58cf6bf169c42595a659b5cb669e191b43d30b0f11906c9cd58 WHIRLPOOL f3a216fb99dac83b32671e520a9aa36068cb33e798a0c952bf423641b259690bfb099ce276b9f7ca966eb0a4cfa6eb27adca324c9c583f99975f137e5c5481eb
+MISC metadata.xml 858 SHA256 699f1f91b9bd22b8ea1f96711eda2df99262bdab3e99aab42f75692b4de776a2 SHA512 cb46245a5f02ad762cb86bb18ca13fee1e9df22c6e1e367c16c9392680722d4852834c6d4d259d7ca71d817ecac22bda120da75513d6f17d243fd8db062f4303 WHIRLPOOL 10a05256415c1ea1577bb96e07c37e264d6178497344ef2f272f886cb6d882e8856b3a55ad001820908f768436e5c8c043ef302229a695d743471ce8f4221d8b
diff --git a/dev-libs/libassuan/libassuan-2.4.3-r1.ebuild b/dev-libs/libassuan/libassuan-2.4.3-r1.ebuild
new file mode 100644
index 000000000000..158bc92f11b4
--- /dev/null
+++ b/dev-libs/libassuan/libassuan-2.4.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit libtool ltprune
+
+DESCRIPTION="IPC library used by GnuPG and GPGME"
+HOMEPAGE="http://www.gnupg.org/related_software/libassuan/index.en.html"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/libgpg-error-1.8"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ elibtoolize
+
+ # fix standards conflict
+ sed -i \
+ -e '/_XOPEN_SOURCE/s/500/600/' \
+ -e 's/_XOPEN_SOURCE_EXTENDED/_NO&/' \
+ -e 's/__EXTENSIONS__/_NO&/' \
+ configure || die
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ # ppl need to use libassuan-config for --cflags and --libs
+ prune_libtool_files
+}
diff --git a/dev-libs/libassuan/metadata.xml b/dev-libs/libassuan/metadata.xml
new file mode 100644
index 000000000000..fe0789259056
--- /dev/null
+++ b/dev-libs/libassuan/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+</maintainer>
+<longdescription>
+In an ideal world, Assuan is irrelevant. Assuan's primary use is to
+allow a client to interact with a non-persistent server. Using Assuan,
+this is accomplished by forking a subprocess and communicating with it
+via, for example, a pipe or unix domain socket. This method is neither
+elegant nor efficient especially when there is a lot of data spread
+across several transactions: not only is there a penalty for an
+increased number of context switches, but also a significant amount of
+data is MEMCPYed from the client to a file descriptor and from the file
+descriptor to the server.
+</longdescription>
+</pkgmetadata>