summaryrefslogtreecommitdiff
path: root/dev-libs/libbson/libbson-1.3.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libbson/libbson-1.3.6.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libbson/libbson-1.3.6.ebuild')
-rw-r--r--dev-libs/libbson/libbson-1.3.6.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libbson/libbson-1.3.6.ebuild b/dev-libs/libbson/libbson-1.3.6.ebuild
new file mode 100644
index 000000000000..89963ad26142
--- /dev/null
+++ b/dev-libs/libbson/libbson-1.3.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A BSON utility library"
+HOMEPAGE="https://github.com/mongodb/libbson"
+SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="debug examples static-libs"
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ default_src_prepare
+ # https://github.com/mongodb/mongo-c-driver/issues/54
+ sed -i -e "s/PTHREAD_LIBS/PTHREAD_CFLAGS/g" src/bson/Makefile.am \
+ tests/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-hardening \
+ --disable-optimizations \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if [[ -f "${D}usr/share/doc/${P}/COPYING" ]] ; then
+ rm "${D}usr/share/doc/${P}/COPYING" || die
+ fi
+
+ # Installing all the manuals conflicts with man-pages
+ doman doc/man/bson_*.3
+ use static-libs || find "${D}" -name '*.la' -delete
+
+ if use examples; then
+ insinto /usr/share/${PF}/examples
+ doins examples/*.c
+ fi
+
+ einstalldocs
+}