summaryrefslogtreecommitdiff
path: root/dev-libs/libbytesize/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /dev-libs/libbytesize/files
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'dev-libs/libbytesize/files')
-rw-r--r--dev-libs/libbytesize/files/libbytesize-2.6-configure-bashism.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libbytesize/files/libbytesize-2.6-configure-bashism.patch b/dev-libs/libbytesize/files/libbytesize-2.6-configure-bashism.patch
new file mode 100644
index 000000000000..5fe0f095eaca
--- /dev/null
+++ b/dev-libs/libbytesize/files/libbytesize-2.6-configure-bashism.patch
@@ -0,0 +1,31 @@
+https://github.com/storaged-project/libbytesize/pull/102
+
+From: Sam James <sam@gentoo.org>
+Date: Fri, 24 Dec 2021 07:58:47 +0000
+Subject: [PATCH] build: avoid bashisms in configure
+
+configure needs to be executable by a POSIX-compliant shell (/bin/sh)
+and while this is often Bash, which tolerates non-POSIX statements, it
+might sometimes be e.g. dash which doesn't.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -59,7 +59,7 @@ AC_ARG_WITH([python3],
+ AC_SUBST(WITH_PYTHON3, 0)
+ if test "x$with_python3" != "xno"; then
+ AC_PATH_PROG([python3], [python3], [no])
+- AS_IF([test "x$python3" == "xno"],
++ AS_IF([test "x$python3" = "xno"],
+ [if test "x$with_python3" = "xyes"; then
+ LIBBYTESIZE_SOFT_FAILURE([Python3 support requested, but python3 is not available])
+ fi],
+@@ -77,7 +77,7 @@ AC_ARG_WITH([gtk-doc],
+ AC_SUBST(WITH_GTK_DOC, 0)
+ if test "x$with_gtk_doc" != "xno"; then
+ AC_PATH_PROG([gtkdoc_scan], [gtkdoc-scan], [no])
+- AS_IF([test "x$gtkdoc_scan" == "xno"],
++ AS_IF([test "x$gtkdoc_scan" = "xno"],
+ [if test "x$with_gtk_doc" = "xyes"; then
+ LIBBYTESIZE_SOFT_FAILURE([Building documentation with gtk-doc requested, but not available])
+ fi],