summaryrefslogtreecommitdiff
path: root/dev-libs/libclthreads/libclthreads-2.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-libs/libclthreads/libclthreads-2.4.2.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-libs/libclthreads/libclthreads-2.4.2.ebuild')
-rw-r--r--dev-libs/libclthreads/libclthreads-2.4.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libclthreads/libclthreads-2.4.2.ebuild b/dev-libs/libclthreads/libclthreads-2.4.2.ebuild
new file mode 100644
index 000000000000..c67a139ad53f
--- /dev/null
+++ b/dev-libs/libclthreads/libclthreads-2.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="POSIX threads C++ access library"
+HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/index.html"
+SRC_URI="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/clthreads-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+S="${WORKDIR}/clthreads-${PV}"
+
+DOCS=( AUTHORS )
+
+PATCHES=(
+ "${FILESDIR}/${P}-Makefile.patch"
+)
+
+src_compile() {
+ cd "${S}"/source || die "Failed to cd to sources"
+ tc-export CXX
+ emake
+}
+
+src_install() {
+ default
+
+ cd "${S}"/source || die "Failed to cd to sources"
+ emake PREFIX="${EPREFIX}/usr" INCDIR="include" LIBDIR="$(get_libdir)" DESTDIR="${ED}" install
+}