summaryrefslogtreecommitdiff
path: root/dev-libs/libdazzle/libdazzle-3.28.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-libs/libdazzle/libdazzle-3.28.5.ebuild
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-libs/libdazzle/libdazzle-3.28.5.ebuild')
-rw-r--r--dev-libs/libdazzle/libdazzle-3.28.5.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libdazzle/libdazzle-3.28.5.ebuild b/dev-libs/libdazzle/libdazzle-3.28.5.ebuild
new file mode 100644
index 000000000000..9dddb0f7f834
--- /dev/null
+++ b/dev-libs/libdazzle/libdazzle-3.28.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org meson xdg vala virtualx
+
+DESCRIPTION="Experimental new features for GTK+ and GLib"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libdazzle"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="gtk-doc +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2
+ x11-libs/gtk+:3[introspection?]
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+# libxml2 required for glib-compile-resources; glib-utils for glib-mkenums
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable_tracing=false # extra trace debugging that would make things slower
+ -Denable_profiling=false # -pg passing
+ # -Denable_rdtscp=false # TODO: CPU_FLAGS_X86 for it?
+ -Denable_tools=true # /usr/bin/dazzle-list-counters
+ $(meson_use introspection with_introspection)
+ $(meson_use vala with_vapi)
+ $(meson_use gtk-doc enable_gtk_doc)
+ $(meson_use test enable_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}