summaryrefslogtreecommitdiff
path: root/dev-libs/libdivsufsort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libdivsufsort
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libdivsufsort')
-rw-r--r--dev-libs/libdivsufsort/Manifest4
-rw-r--r--dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild22
-rw-r--r--dev-libs/libdivsufsort/libdivsufsort-9999.ebuild23
-rw-r--r--dev-libs/libdivsufsort/metadata.xml11
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/libdivsufsort/Manifest b/dev-libs/libdivsufsort/Manifest
new file mode 100644
index 000000000000..5ccfd281d516
--- /dev/null
+++ b/dev-libs/libdivsufsort/Manifest
@@ -0,0 +1,4 @@
+DIST libdivsufsort-2.0.1.tar.gz 31290 BLAKE2B cf8d5259adbef828dc1650d57969001f23b65d064658af4333d6bd86ec2ca0618f92d21e50e135eec7102b142ead15c3cc53bdba0d9d336507578db36b92edc4 SHA512 c82299adbd49995145872cd67e03b1c8762de99043acca48964b16c66a39347fb6211b17c9b5f6e12878983ea7cafa65991179f67e3a4cb5e5e14bb57775487e
+EBUILD libdivsufsort-2.0.1.ebuild 550 BLAKE2B f2b3424d4fbef0a1c6a43cb150a6c834ec316892ccd9c154d997b17de88bbd9f006b57cf0953489060f34e63c8203c9165ea514127913df1f7956b0f39f3ce92 SHA512 f1a785a2b7f1398f872a72dc556b3250c6abd3467426e08af579c09bc9915ba1d72a132677fba1db6cf03b2b60c1efa32308efd8eb91b78ea66d74c215a3b493
+EBUILD libdivsufsort-9999.ebuild 527 BLAKE2B 129107c4844bc055213ddbedb330646cdbe2896812fea90419c66b0c3bb6dc71477b24d2b390434d6442381252081145ffb911f8c1819753c628eb62059fd2f7 SHA512 f77d3a8450c9bbe13a866b8dc0b81320b985862de33387d69886c2448656013b877d0f1c308bf07a20c27de05b72e8900d881984ed09bbb88a2151a0a8686fc5
+MISC metadata.xml 331 BLAKE2B aeb4281b9559ab0e91ed011c9a695e8af8bb2613a54b6b49a6629f952c26607704995d274033132726e21a51a296fd4efee6d090cc022d0db08476003d1a6529 SHA512 44257e79147e95579eff4b63be25a6ec673f8a2a09e7b2240163260c3f13161585746bf9967f479aaf6094271669f1b16202a1c5766c3c638a4f9054dd9408fc
diff --git a/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild b/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
new file mode 100644
index 000000000000..f507682f32d4
--- /dev/null
+++ b/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils multilib
+
+DESCRIPTION="Suffix-sorting library (for BWT)"
+HOMEPAGE="https://github.com/y-256/libdivsufsort"
+SRC_URI="https://github.com/y-256/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # will appreciate saner approach, if there is any
+ sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
+ */CMakeLists.txt || die
+}
diff --git a/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild b/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
new file mode 100644
index 000000000000..9dcaf6470b58
--- /dev/null
+++ b/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGIT_REPO_URI="https://github.com/y-256/${PN}"
+inherit cmake-utils multilib git-r3
+
+DESCRIPTION="Suffix-sorting library (for BWT)"
+HOMEPAGE="https://github.com/y-256/libdivsufsort"
+SRC_URI=""
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # will appreciate saner approach, if there is any
+ sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
+ */CMakeLists.txt || die
+}
diff --git a/dev-libs/libdivsufsort/metadata.xml b/dev-libs/libdivsufsort/metadata.xml
new file mode 100644
index 000000000000..99ce3469fc7a
--- /dev/null
+++ b/dev-libs/libdivsufsort/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">y-256/libdivsufsort</remote-id>
+ </upstream>
+</pkgmetadata>