summaryrefslogtreecommitdiff
path: root/dev-libs/libdnet/libdnet-1.18.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-24 01:01:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-24 01:01:06 +0000
commitf52562a45d967e193210737b55de5f0ff9018b76 (patch)
tree909caa133f3a538fde8ed9dfd9efa42a2c7a0507 /dev-libs/libdnet/libdnet-1.18.0.ebuild
parent36fc50e36ed1a4686bb7202aeaff3170b2206124 (diff)
gentoo auto-resync : 24:03:2024 - 01:01:06
Diffstat (limited to 'dev-libs/libdnet/libdnet-1.18.0.ebuild')
-rw-r--r--dev-libs/libdnet/libdnet-1.18.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-libs/libdnet/libdnet-1.18.0.ebuild b/dev-libs/libdnet/libdnet-1.18.0.ebuild
index acb3b2536aa4..fd47d46e0186 100644
--- a/dev-libs/libdnet/libdnet-1.18.0.ebuild
+++ b/dev-libs/libdnet/libdnet-1.18.0.ebuild
@@ -17,8 +17,7 @@ LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE="python test"
-# Tests fail in sandbox
-RESTRICT="!test? ( test ) test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="
@@ -75,6 +74,12 @@ src_compile() {
fi
}
+src_test() {
+ # https://bugs.gentoo.org/778797#c4
+ # check_ip needs privileges and check_fw can't work on Linux
+ emake check XFAIL_TESTS="check_fw check_ip"
+}
+
src_install() {
default