summaryrefslogtreecommitdiff
path: root/dev-libs/libdynd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-libs/libdynd
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libdynd')
-rw-r--r--dev-libs/libdynd/Manifest3
-rw-r--r--dev-libs/libdynd/libdynd-0.7.2.ebuild78
-rw-r--r--dev-libs/libdynd/metadata.xml25
3 files changed, 0 insertions, 106 deletions
diff --git a/dev-libs/libdynd/Manifest b/dev-libs/libdynd/Manifest
deleted file mode 100644
index a8dfba295838..000000000000
--- a/dev-libs/libdynd/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST libdynd-0.7.2.tar.gz 1342364 BLAKE2B 28617a6b01c09dd8030d376f73c6dc6ddb4cd031aaa59348283fbb1226bb401e2d7ab48385263b8abc4ca95ffd75d2ce9f3b52a417fe04c6597886f8626cdd3f SHA512 134195ba5839e05af07dd9ad0b8e749a83345511acd2a22a029a4d9a2c0fc77a8a1f36722bce20653d28189b7883afe7feb651c7d32ff921ef257a8a9aa4bd7f
-EBUILD libdynd-0.7.2.ebuild 2070 BLAKE2B 23a9f3d75e6ffb109a2e52cbc2d6aac26bc6e900b8996b6b0812f99f95ccfb81d385f9b8f40652e4cda8e5891672da0ec5d51570921cc3a86b17cec91a428621 SHA512 0f327413a749969c9bcc9823b6677119d0ab7be52d6516ea6ef046131085877ffe744f08e1b7db4da7bf431271480415f3ff4181fe06cd9db419a24f16aec0dc
-MISC metadata.xml 1120 BLAKE2B 9b42962d156122337c1e142a67a984aa8a2537a3e14b8273d18e749a2e4887e8694623eaf2d74b8beb463ac9070c73d5d0f0bd34e6f800b735e3151e1fd8616a SHA512 ac2eb8493d3e23ec7bdac5d3d5dc2d22358e51e468456de99b5bc48326924c1db31ea4d9474300a2579203d25ebb863ac84226529b36b6b1402e1351c03b1b68
diff --git a/dev-libs/libdynd/libdynd-0.7.2.ebuild b/dev-libs/libdynd/libdynd-0.7.2.ebuild
deleted file mode 100644
index bd2fb462f18f..000000000000
--- a/dev-libs/libdynd/libdynd-0.7.2.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils cuda
-
-# change each new libdynd version, to avoid git in tree dependency
-DYND_GIT_SHA1=341d6d91931fdb04ad657d27ed740cf533fc925b
-
-DESCRIPTION="C++ dynamic multi-dimensionnal array library with Python exposure"
-HOMEPAGE="http://libdynd.org"
-SRC_URI="https://github.com/libdynd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="cuda doc fftw mkl test"
-
-RDEPEND="
- dev-libs/c-blosc:0=
- cuda? ( dev-util/nvidia-cuda-toolkit )
- fftw? ( sci-libs/fftw:3.0 )
-"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )
-"
-
-DOCS=( README.md )
-
-src_prepare() {
- use cuda && cuda_src_prepare
- cmake-utils_src_prepare
- cmake_comment_add_subdirectory examples
- # fix forced cxxflags and doc installation directory
- sed -e 's|-O3 -fomit-frame-pointer||' \
- -e 's|-Werror||g' \
- -e "s|docs DESTINATION docs|docs/html DESTINATION share/doc/${PF}|" \
- -i CMakeLists.txt || die
- # don't install test exec
- sed -e 's|install(TARGETS test_libdynd||' \
- -e 's|RUNTIME DESTINATION bin)||' \
- -i tests/CMakeLists.txt || die
- # remove the version mangling from git stuff it requires a git clone
- # rather force set it a configure time
- sed -e '/GetGitRev/d' \
- -e '/get_git_/d' \
- -e '/git_describe/d' \
- -e '/dirty/d' \
- -i CMakeLists.txt || die
- # not tested
- if use mkl; then
- sed -e "s|/opt/intel/.*|$(ls -1d ${EPREFIX}/opt/intel/compilers*)|" \
- -i tests/CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DDYND_GIT_SHA1="${DYND_GIT_SHA1}"
- -DDYND_VERSION_STRING="v${PV}"
- -DDYND_INSTALL_LIB=ON
- -DDYND_SHARED_LIB=ON
- -DDYND_BUILD_BENCHMARKS=OFF
- -DDYND_BUILD_DOCS="$(usex doc)"
- -DDYND_BUILD_PLUGIN="$(usex mkl)"
- -DDYND_BUILD_TESTS="$(usex test)"
- -DDYND_CUDA="$(usex cuda)"
- -DDYND_FFTW="$(usex fftw)"
- -DFFTW_PATH="${EPREFIX}/usr/include"
- )
- cmake-utils_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}" || die
- ./tests/test_libdynd || die
-}
diff --git a/dev-libs/libdynd/metadata.xml b/dev-libs/libdynd/metadata.xml
deleted file mode 100644
index 0b3978ba39fe..000000000000
--- a/dev-libs/libdynd/metadata.xml
+++ /dev/null
@@ -1,25 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- LibDyND, a component of the Blaze project, is a C++ library for
- dynamic, multidimensional arrays. It is inspired by NumPy, the
- Python array programming library at the core of the scientific
- Python stack, but tries to address a number of obstacles encountered
- by some of its users. Examples of this are support for
- variable-sized string and ragged array types. The library is in a
- preview development state, and can be thought of as a sandbox where
- features are being tried and tweaked to gain experience with them.
- </longdescription>
- <use>
- <flag name="cuda">Enable NVIDIA CUDA toolkit support</flag>
- <flag name="mkl">Enable a plugin for Intel Math Kernel Library <pkg>sci-libs/mkl</pkg></flag>
- </use>
- <upstream>
- <remote-id type="github">libdynd/libdynd</remote-id>
- </upstream>
-</pkgmetadata>