summaryrefslogtreecommitdiff
path: root/dev-libs/libgpiod
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-21 20:44:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-21 20:44:55 +0100
commitaa870ba91722a8d38ba5103297a6aa4abb54e5bc (patch)
treef91c8d19a619a57e109d68ad33c2b791a35df473 /dev-libs/libgpiod
parent2480f36bfb3d39469cc44843d1fe664bd40443a3 (diff)
gentoo auto-resync : 21:07:2022 - 20:44:55
Diffstat (limited to 'dev-libs/libgpiod')
-rw-r--r--dev-libs/libgpiod/Manifest2
-rw-r--r--dev-libs/libgpiod/libgpiod-1.6.3-r1.ebuild (renamed from dev-libs/libgpiod/libgpiod-1.6.3.ebuild)9
2 files changed, 8 insertions, 3 deletions
diff --git a/dev-libs/libgpiod/Manifest b/dev-libs/libgpiod/Manifest
index a9d2bc86eaac..3152e8b8f855 100644
--- a/dev-libs/libgpiod/Manifest
+++ b/dev-libs/libgpiod/Manifest
@@ -1,5 +1,5 @@
DIST libgpiod-1.4.1.tar.xz 314936 BLAKE2B 8949c4a96f69a83a479f5951e6f1eb8fee56db700e72320131c365a5d736a48700fb42b7ecc2b676cec54887eaa650075f45ec1f0b803de914958cefd3863db8 SHA512 2a9c58a46fb3c2e2dd15cc4ba52f589b44e5ae4547226eeb68a8e5bea6292d38aaf0889cc639e0979e12e129bb944bb42d9258f10292f59d074660e7c2d56d04
DIST libgpiod-1.6.3.tar.xz 326068 BLAKE2B eda5409f2db3914ede92690589643211eca3002f8dc53a7c48213602f28158084c8eb8061319923f7a51c7d91650ff58b81b059323b5b9133a28b0bb04f6904d SHA512 f7e48662d02904f3f25976d61aa2cf4af0b8a52f65f184f23dfb6916bde9b86634b211f2696d3459a4f902ba5a79621b2fc47d18d487fd7a159018fe8933e370
EBUILD libgpiod-1.4.1.ebuild 1165 BLAKE2B 190c2b8c0bfaf71973fb722717798b663ca73486f2b9724bfe53f4931169cf055451a7bf7fdabccc0689c5e0e148c99596cf3081b75ebdb759de4c562c07ae55 SHA512 b77d0c3b7f7354b99bb648312fb794253cdda9bdf333d29c34e563e4965555a35c201d3568a7881cd123a81fe7a8f48568680c60e2cdcdb728128eb1057a3846
-EBUILD libgpiod-1.6.3.ebuild 1169 BLAKE2B 60f7bbcbcb5cbc9dfaac76147db9892a7ea1b6e56377e18f93bde0e6d8b9c18e121d5e9ea48d90fb3819e028ea507b59ed5c24b9537fddd69b09a593633d8e8f SHA512 d79372e2ae3b5884282ac3b96acc1984a7bc425a962812c81ecf8175b90e0b14ecd89d2b6c2b7a0be05f7f5427bde8aa5672ece562ea40d509b65f657ebbc47e
+EBUILD libgpiod-1.6.3-r1.ebuild 1246 BLAKE2B 99cc22bc24182640da69aa0b22a2880bd2c7e866d093330955cb121f73ac9a83cd9af4a30f6512be990c789e291871482a8d038b57907b71efe06c64032c1c33 SHA512 9825b05d687a5f7ecdc23b9ef88f0432e15f8d7fb8090be513ea14521b306c24b3a3ee9c085bf275027aaf4c40e2c7995a76b16863c94816289c71ce5360fbab
MISC metadata.xml 344 BLAKE2B 3c4f791ae16ba0fa5e2d061ee5aa6795f39b4b2224643b564fcb5f2368a42e349a8d1fa57413a475d48f7038371af321d4758be99658842246403212a22321f3 SHA512 b2d8068c46c3478e2d2251d74f81657c7fcbc320b8d35a56f36e609a118f6858eb62c7905da35ba39c0ae2c98a6bcd0c13418bb9f14176c0d887b5df505a4374
diff --git a/dev-libs/libgpiod/libgpiod-1.6.3.ebuild b/dev-libs/libgpiod/libgpiod-1.6.3-r1.ebuild
index 8f3fe8c74ec2..a0b6d335709c 100644
--- a/dev-libs/libgpiod/libgpiod-1.6.3.ebuild
+++ b/dev-libs/libgpiod/libgpiod-1.6.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multilib-minimal
+inherit linux-mod multilib-minimal
DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
@@ -20,6 +20,11 @@ RESTRICT="!test? ( test )"
# --enable-bindings-cxx enable C++ bindings [default=no]
# --enable-bindings-python
+pkg_setup() {
+ CONFIG_CHECK="GPIO_CDEV_V1"
+ linux-mod_pkg_setup
+}
+
multilib_src_configure() {
local myconf=(
$(use_enable tools)