summaryrefslogtreecommitdiff
path: root/dev-libs/libgweather/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-libs/libgweather/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-libs/libgweather/files')
-rw-r--r--dev-libs/libgweather/files/3.36.1-autoskip-network-test.patch30
-rw-r--r--dev-libs/libgweather/files/3.36.2-autoskip-network-test.patch29
-rw-r--r--dev-libs/libgweather/files/40.0-autoskip-network-test.patch29
-rw-r--r--dev-libs/libgweather/files/40.0-meson-tweaks.patch109
-rw-r--r--dev-libs/libgweather/files/40.0-tests-locale.patch55
5 files changed, 222 insertions, 30 deletions
diff --git a/dev-libs/libgweather/files/3.36.1-autoskip-network-test.patch b/dev-libs/libgweather/files/3.36.1-autoskip-network-test.patch
deleted file mode 100644
index d6b3d2f61313..000000000000
--- a/dev-libs/libgweather/files/3.36.1-autoskip-network-test.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From f2bacee194ce58aabf5a08752556177bda6ab570 Mon Sep 17 00:00:00 2001
-From: Mart Raudsepp <leio@gentoo.org>
-Date: Sun, 30 Aug 2020 10:35:13 +0300
-Subject: [PATCH] tests: Skip metar tests when METAR_SOURCES couldn't be
- resolved
-
----
- libgweather/test_libgweather.c | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/libgweather/test_libgweather.c b/libgweather/test_libgweather.c
-index 8a21911..ef401f8 100644
---- a/libgweather/test_libgweather.c
-+++ b/libgweather/test_libgweather.c
-@@ -419,6 +419,12 @@ test_metar_weather_stations (void)
- msg = soup_message_new ("GET", METAR_SOURCES);
- session = soup_session_new ();
- soup_session_send_message (session, msg);
-+ if (msg->status_code == SOUP_STATUS_CANT_RESOLVE) {
-+ g_test_skip ("Could not resolve " METAR_SOURCES " - network sandboxed?");
-+ g_object_unref (session);
-+ g_object_unref (msg);
-+ return;
-+ }
- g_assert (SOUP_STATUS_IS_SUCCESSFUL (msg->status_code));
- g_object_unref (session);
- g_assert_nonnull (msg->response_body);
---
-2.20.1
-
diff --git a/dev-libs/libgweather/files/3.36.2-autoskip-network-test.patch b/dev-libs/libgweather/files/3.36.2-autoskip-network-test.patch
new file mode 100644
index 000000000000..bc35bb3c4fd5
--- /dev/null
+++ b/dev-libs/libgweather/files/3.36.2-autoskip-network-test.patch
@@ -0,0 +1,29 @@
+From 4bc5b6792706788f0930bda7049adf349713a2cc Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 30 Aug 2020 10:35:13 +0300
+Subject: [PATCH] tests: Skip metar tests when METAR_SOURCES couldn't be
+ resolved
+
+---
+ libgweather/test_libgweather.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/libgweather/test_libgweather.c b/libgweather/test_libgweather.c
+index b481278d..5704bd8b 100644
+--- a/libgweather/test_libgweather.c
++++ b/libgweather/test_libgweather.c
+@@ -424,6 +424,11 @@ test_metar_weather_stations (void)
+ g_test_message ("SSL/TLS failure, please check your glib-networking installation");
+ g_test_failed ();
+ return;
++ } else if (msg->status_code == SOUP_STATUS_CANT_RESOLVE) {
++ g_test_skip ("Could not resolve " METAR_SOURCES " - network sandboxed?");
++ g_object_unref (session);
++ g_object_unref (msg);
++ return;
+ }
+ g_assert_cmpint (msg->status_code, >=, 200);
+ g_assert_cmpint (msg->status_code, <, 300);
+--
+2.26.2
+
diff --git a/dev-libs/libgweather/files/40.0-autoskip-network-test.patch b/dev-libs/libgweather/files/40.0-autoskip-network-test.patch
new file mode 100644
index 000000000000..def65382613b
--- /dev/null
+++ b/dev-libs/libgweather/files/40.0-autoskip-network-test.patch
@@ -0,0 +1,29 @@
+From 1d0ae284635ef1975a581b4d73ab497ccbd4532f Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 30 Aug 2020 10:35:13 +0300
+Subject: [PATCH 2/2] tests: Skip metar tests when METAR_SOURCES couldn't be
+ resolved
+
+---
+ libgweather/test_libgweather.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/libgweather/test_libgweather.c b/libgweather/test_libgweather.c
+index ee13dc7b..7ffaac41 100644
+--- a/libgweather/test_libgweather.c
++++ b/libgweather/test_libgweather.c
+@@ -438,6 +438,11 @@ test_metar_weather_stations (void)
+ g_test_message ("SSL/TLS failure, please check your glib-networking installation");
+ g_test_failed ();
+ return;
++ } else if (msg->status_code == SOUP_STATUS_CANT_RESOLVE) {
++ g_test_skip ("Could not resolve " METAR_SOURCES " - network sandboxed?");
++ g_object_unref (session);
++ g_object_unref (msg);
++ return;
+ }
+ g_assert_cmpint (msg->status_code, >=, 200);
+ g_assert_cmpint (msg->status_code, <, 300);
+--
+2.26.2
+
diff --git a/dev-libs/libgweather/files/40.0-meson-tweaks.patch b/dev-libs/libgweather/files/40.0-meson-tweaks.patch
new file mode 100644
index 000000000000..aa56c592890f
--- /dev/null
+++ b/dev-libs/libgweather/files/40.0-meson-tweaks.patch
@@ -0,0 +1,109 @@
+From bbf17eac53c128904190ef2d74176b0717d7d907 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sat, 23 Feb 2019 12:21:01 +0200
+Subject: [PATCH] build: Provide introspection option and don't build manual
+ tests
+
+---
+ libgweather/meson.build | 21 ++++++++++++++-------
+ meson.build | 4 ++++
+ meson_options.txt | 2 ++
+ 3 files changed, 20 insertions(+), 7 deletions(-)
+
+diff --git a/libgweather/meson.build b/libgweather/meson.build
+index 26f067e6..8f0f9047 100644
+--- a/libgweather/meson.build
++++ b/libgweather/meson.build
+@@ -74,6 +74,15 @@ lib_libgweather = shared_library('gweather-3',
+ install: true,
+ )
+
++libgweather_dep = declare_dependency(
++ sources: [gweather_enum_types[1]],
++ dependencies: deps_libgweather,
++ link_with: lib_libgweather,
++ include_directories: root_inc,
++)
++
++if get_option('introspection')
++
+ gweather_gir = gnome.generate_gir(lib_libgweather,
+ sources: introspection_sources,
+ dependencies: deps_libgweather,
+@@ -91,13 +100,6 @@ gweather_gir = gnome.generate_gir(lib_libgweather,
+ install: true,
+ )
+
+-libgweather_dep = declare_dependency(
+- sources: [gweather_enum_types[1], gweather_gir],
+- dependencies: deps_libgweather,
+- link_with: lib_libgweather,
+- include_directories: root_inc,
+-)
+-
+ if enable_vala
+ gnome.generate_vapi('gweather-3.0',
+ sources: gweather_gir[0],
+@@ -106,11 +108,13 @@ if enable_vala
+ install: true
+ )
+ endif
++endif
+
+ test_cargs = ['-DTEST_LOCATIONS="@0@"'.format(locations_bin.full_path()),
+ '-DSCHEMASDIR="@0@/schemas"'.format(meson.source_root()),
+ '-DSCHEMAS_BUILDDIR="@0@/schemas"'.format(meson.build_root())]
+
++if false
+ executable('test_locations',
+ ['test_locations.c'],
+ c_args: test_cargs,
+@@ -121,6 +125,7 @@ executable('test_locations_utc',
+ c_args: test_cargs,
+ dependencies: libgweather_dep,
+ install: false)
++endif
+
+ exe = executable('test_libgweather',
+ ['test_libgweather.c'],
+@@ -129,6 +134,7 @@ exe = executable('test_libgweather',
+ install: false)
+ test('test_libgweather', exe, depends: [locations_bin])
+
++if false
+ executable('test_metar',
+ ['test_metar.c', gweather_c_sources],
+ c_args: test_cargs,
+@@ -144,3 +150,4 @@ executable('test_weather',
+ c_args: test_cargs,
+ dependencies: libgweather_dep,
+ install: false)
++endif
+diff --git a/meson.build b/meson.build
+index 87f9a7d8..48ff0ca2 100644
+--- a/meson.build
++++ b/meson.build
+@@ -104,6 +104,10 @@ else
+ enable_vala = enable_vala != 'false'
+ endif
+
++if enable_vala and not get_option('introspection')
++ error('Vala bindings require introspection support')
++endif
++
+ root_inc = include_directories('.')
+
+ subdir('data')
+diff --git a/meson_options.txt b/meson_options.txt
+index 19b2c6a7..bf4c5175 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -8,3 +8,5 @@ option('enable_vala', type: 'combo', choices : ['true', 'false', 'auto'], value
+ description: 'Install vala bindings')
+ option('gtk_doc', type: 'boolean', value: false,
+ description: 'Whether to generate the API reference')
++option('introspection', type: 'boolean', value: true,
++ description: 'generate GObject Introspection data')
+--
+2.26.2
+
diff --git a/dev-libs/libgweather/files/40.0-tests-locale.patch b/dev-libs/libgweather/files/40.0-tests-locale.patch
new file mode 100644
index 000000000000..ea1f6020152d
--- /dev/null
+++ b/dev-libs/libgweather/files/40.0-tests-locale.patch
@@ -0,0 +1,55 @@
+From 6b2801a8195990fdf5166b62f62ddfbad55f11e4 Mon Sep 17 00:00:00 2001
+From: Emmanuele Bassi <ebassi@gnome.org>
+Date: Mon, 9 Mar 2020 12:21:57 +0000
+Subject: [PATCH 1/2] Do not run local-dependent tests with missing locales
+
+Not everyone has all the locales installed all the time, so let's check
+if a locale is available before using it.
+---
+ libgweather/test_libgweather.c | 12 +++++++++++-
+ 1 file changed, 11 insertions(+), 1 deletion(-)
+
+diff --git a/libgweather/test_libgweather.c b/libgweather/test_libgweather.c
+index b10c1f16..ee13dc7b 100644
+--- a/libgweather/test_libgweather.c
++++ b/libgweather/test_libgweather.c
+@@ -678,6 +678,7 @@ test_location_names (void)
+ {
+ g_autoptr(GWeatherLocation) world = NULL;
+ g_autoptr(GWeatherLocation) brussels = NULL;
++ char *old_locale;
+
+ world = gweather_location_get_world ();
+ g_assert_nonnull (world);
+@@ -689,10 +690,19 @@ test_location_names (void)
+ g_assert_cmpstr (gweather_location_get_english_name (brussels), ==, "Brussels");
+ gweather_location_unref (brussels);
+
++ old_locale = g_strdup (setlocale (LC_ALL, NULL));
+ setlocale (LC_ALL, "fr_FR.UTF-8");
+
+ g_clear_pointer (&world, gweather_location_unref);
+ g_clear_pointer (&brussels, gweather_location_unref);
++ if (strstr (setlocale (LC_ALL, NULL), "fr_FR.UTF-8") == NULL)
++ {
++ g_test_skip ("locale fr_FR.UTF-8 not available, skipping localization tests");
++ setlocale (LC_ALL, old_locale);
++ g_free (old_locale);
++ return;
++ }
++
+ _gweather_location_reset_world ();
+
+ world = gweather_location_get_world ();
+@@ -705,7 +715,7 @@ test_location_names (void)
+ g_assert_cmpstr (gweather_location_get_english_name (brussels), ==, "Brussels");
+ gweather_location_unref (brussels);
+
+- setlocale (LC_ALL, "");
++ setlocale (LC_ALL, old_locale);
+ g_clear_pointer (&world, gweather_location_unref);
+ g_clear_pointer (&brussels, gweather_location_unref);
+ _gweather_location_reset_world ();
+--
+2.26.2
+