summaryrefslogtreecommitdiff
path: root/dev-libs/libinput
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-libs/libinput
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest2
-rw-r--r--dev-libs/libinput/libinput-1.20.1.ebuild88
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 7f5a015b2b6c..2419a431b860 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,5 +1,7 @@
DIST libinput-1.19.3.tar.xz 655164 BLAKE2B a07d91603a3d4e759aad25ee46b11dbee47eb013a2361f1b70acd616fee0ed9660e6fa8773948d6acf3686179fd7aaf76bf8285f3dc3137a4b1b605ec0e4d6d2 SHA512 f4b776d0da78c687ba21b430a04941ac6b43f68970c82ec9f7360358fdea5ed6a873948ce66a25bcdd64d4b95fa4bf705cc24dbc25c7c0f5fd2d0efbd763f298
DIST libinput-1.20.0.tar.gz 982547 BLAKE2B 6a30ec5473b7271b89a50cb5147900928bc1ac370cb30bb7a9282517f9ced1973e7f83e864a865c840a1f1fe447459c329b8966211cafcd28f8d1285a36de593 SHA512 b92345809f4e18b2335e3c377d1a8edda523462ff23fba6abcc5f8cf01b80fc4c6e4e06886088788c4b04873d37da210876f201bb81203af2f9f614bc659e6eb
+DIST libinput-1.20.1.tar.gz 983069 BLAKE2B 8e63e286c0c4284f4a61129d8b6394e7ca9f2018c6a2781a7fe4b7389120dcaf5c101ccfb4b0b869afc489999e954ce244213b5d206ff546d698068e738ac853 SHA512 91f6d6957b16d76807b376d4f81333ed16218fd37b090417d03a2e551d1f5b2c734d891d267bcdc4314cd698d7830f2f467389a9af58155e4e97a86002c8db78
EBUILD libinput-1.19.3.ebuild 2260 BLAKE2B 5ff2aed88d53ebaee2c869ac6173fa946cc324ad58a1918105571dcc21e191fb2a94d95326aa74fcc77603ece590807878861ddbab63f38948bb4e186a93983d SHA512 0e1da4863310b22e9fa96c1b353091da77c406788adc282483dd5c376085d27b8b8809a7751276e3e5ca6be38e96df5c8c96ec9530c5b13982e8ccc7340f16db
EBUILD libinput-1.20.0.ebuild 2283 BLAKE2B 867defe25d1b809da4b6bafcc8a8d5fd6c8b07194fef4492234196a64bb5ead4e55a11022ac7da584908e91fedda9f44f13bec464693ef1e2039ea4dcd94e3c4 SHA512 d77f2cd866cca6b86cbe420650ddff486a84e04d9b35f272184d3353049663d97dfd7bb8ba94a285416dbd2471c37c1a8a346fd88e3a5178039c4b63308a9884
+EBUILD libinput-1.20.1.ebuild 2284 BLAKE2B 84c831b0d0f11e999e5575865bac97a2da5ebfe53bbcdbeeb78497f075f0fc61ea3b61d382c63181c78ebd32f0a80b489403b05f3a73468497fab0df5cbaf610 SHA512 3ba231e3fcb916bfd6e5a6472e905fe89e3ddd04242bcc45c94c04cb3002624d32d045a3361281f852c8656770c0b21a4f4f2c8e2b5b3162f84c1c47fa71ac09
MISC metadata.xml 449 BLAKE2B 677e5fee3bf4047ba47b90aca7f30b9ce57e947e6b5f6903cbb93c214b084f0d93f6253980090544d4ff4a821263c156e0706ae5499cacbb2e52d629f3a7b253 SHA512 103e8b39ad6b9ffde159095dbc4553d8b695db44e49582518055313c79ff6123bcc424c3980cbbaeabaa455e00a828039f73c1f3424ce038d5a2d63ed3e7849d
diff --git a/dev-libs/libinput/libinput-1.20.1.ebuild b/dev-libs/libinput/libinput-1.20.1.ebuild
new file mode 100644
index 000000000000..6182a2f61425
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.20.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 2014-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-any-r1 udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/10"
+[[ "$(ver_cut 3)" -gt 900 ]] || \
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE="doc input_devices_wacom test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ $(python_gen_any_dep '
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
+ ')
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? ( dev-util/valgrind )
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.27 )
+ >=dev-libs/libevdev-1.9.902
+ >=sys-libs/mtdev-1.1
+ virtual/libudev:=
+ virtual/udev
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/check-0.9.10 )"
+
+python_check_deps() {
+ has_version -b "dev-python/commonmark[${PYTHON_USEDEP}]" && \
+ has_version -b "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
+ has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]" && \
+ has_version -b ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed "s@, '-Werror'@@" -i meson.build || die #744250
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ $(meson_use doc documentation)
+ $(meson_use input_devices_wacom libwacom)
+ $(meson_use test tests)
+ -Dudev-dir="${EPREFIX}$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/Documentation/.
+ fi
+}
+
+pkg_postinst() {
+ pkgname="dev-python/python-libevdev"
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! has_version "${pkgname}" ; then
+ einfo "${pkgname} must be installed to use the"
+ einfo "libinput measure and libinput replay tools."
+ fi
+
+ udevadm hwdb --update --root="${ROOT}"
+}