summaryrefslogtreecommitdiff
path: root/dev-libs/libinput
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-20 03:02:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-20 03:02:59 +0000
commit8a5f3383bbc5f817d89554020a3600d06985bc4a (patch)
treec1f7e85e7de87c74b4c730fab5369051cef5cb32 /dev-libs/libinput
parentf2e359c456b051f95efc92e21299d55a302e58ed (diff)
gentoo auto-resync : 20:11:2024 - 03:02:59
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest2
-rw-r--r--dev-libs/libinput/libinput-1.27.0.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index d3f70ac4a8e4..ebc71efe28d5 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,3 +1,5 @@
DIST libinput-1.26.2.tar.bz2 824312 BLAKE2B df463f377cf2f246f6b5b35bdc69039830b4eb5b836a8df9698330140b1bc4b31c7dd50d8ffdec7c935e8b14909d98436ce8f1f9a6d0120e4b72f29381f9b697 SHA512 51fab62e1bfb6007287e1219bf458a351806ce685e6e7ba5360062c863f0811da75acc6ec92aef7f9e0556dac0413fbe43a4744885f7449e38036130112907a6
+DIST libinput-1.27.0.tar.bz2 843722 BLAKE2B 342166bc48943a65e70be274a4b946769b27029b8d3014b081f268537c7bbdf5c7e9be5e2c2b547e1433e444c9e5b2994a4d03f7894afe15b923ba09cd58d490 SHA512 ddfb4a16cbd40f8e55a536f8e18e77bb26113690bd4188d2e6ea04c1a906d8392d4df340d4e24f20c5152b3ef7d727702229a86fc27ad50c5ea9a85a58d3e24a
EBUILD libinput-1.26.2.ebuild 2373 BLAKE2B 05f4b599a866481fb5be923377db9b033214418fec1328ebaf83edb3dc94f7ca2014de9f2bd843fe57311bca22aede445d9e6cbdaba7b8bc66a7a7ed79edd9a1 SHA512 fb7a22f39d22340bb5f2a8e7a68b354cf34d5ff694cb542900631ad7f52e1c819c4edef20485c11ff79147fa8ce89520816ef98491550363741c33b2d7c0eee8
+EBUILD libinput-1.27.0.ebuild 2380 BLAKE2B fd68d7ad8a53c2faa0b89e4265f066881cb6d11572e2fad596f4f6540492e75adce6a57060b0bd0ffe95b3418c2a4b0eb0b6b79d044da300faff2fccc221affc SHA512 d91e399fef8c34cd09f46c2ad130692b6ff4f71aa5442f8c7f1243158601d5a9e4b5e9ec89c5a3effca27a280455c866f9f101d6afcc5fa50eda2cd7376f6c11
MISC metadata.xml 339 BLAKE2B c649f0ffaad1b1dc76c3d3184d95356b2925f642ff6b96c3eba0c31a1d96c3d9b741c1348f8ec90d02428c30a836872fe4e42e7ab5f5e5197f4a787f9147a1a8 SHA512 e9aeca6cc4451ab5b622f597f8debaecfdc672244e5e0b687ac294c20009ba42fb2ccc45e7016a2427312e1c768259005e0a7ff53026087570382652ec23cb60
diff --git a/dev-libs/libinput/libinput-1.27.0.ebuild b/dev-libs/libinput/libinput-1.27.0.ebuild
new file mode 100644
index 000000000000..2dcde3640a39
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.27.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 2014-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit meson optfeature python-any-r1 udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/10"
+if [[ $(ver_cut 3) -lt 900 ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+IUSE="doc input_devices_wacom test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.27:= )
+ >=dev-libs/libevdev-1.9.902
+ >=sys-libs/mtdev-1.1
+ virtual/libudev:=
+ virtual/udev
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-libs/check-0.9.10 )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ $(python_gen_any_dep '
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-rtd-theme-0.2.4[${PYTHON_USEDEP}]
+ ')
+ >=app-text/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+ test? (
+ $(python_gen_any_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ ')
+ )
+"
+# test? ( dev-debug/valgrind )
+
+python_check_deps() {
+ if use doc; then
+ python_has_version \
+ "dev-python/commonmark[${PYTHON_USEDEP}]" \
+ "dev-python/recommonmark[${PYTHON_USEDEP}]" \
+ "dev-python/sphinx[${PYTHON_USEDEP}]" \
+ ">=dev-python/sphinx-rtd-theme-0.2.4[${PYTHON_USEDEP}]" \
+ || return
+ fi
+ if use test; then
+ python_has_version \
+ "dev-python/pytest[${PYTHON_USEDEP}]" \
+ "dev-python/pytest-xdist[${PYTHON_USEDEP}]" \
+ || return
+ fi
+}
+
+src_prepare() {
+ default
+ sed "s@, '-Werror'@@" -i meson.build || die #744250
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ $(meson_use doc documentation)
+ $(meson_use input_devices_wacom libwacom)
+ $(meson_use test tests)
+ -Dudev-dir="${EPREFIX}$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/Documentation/.
+ fi
+}
+
+pkg_postinst() {
+ optfeature "measure and replay tools" dev-python/libevdev
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}