summaryrefslogtreecommitdiff
path: root/dev-libs/libinput
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-libs/libinput
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest4
-rw-r--r--dev-libs/libinput/libinput-1.16.2.ebuild88
-rw-r--r--dev-libs/libinput/libinput-1.16.3.ebuild88
3 files changed, 180 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 234755d69f65..d5391aefb65c 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,3 +1,7 @@
DIST libinput-1.16.1.tar.xz 595548 BLAKE2B 497089248c2104ff7784b7d46d8e846047e054f01c6ea192f1c41171b39213fa1f19be8c8253c32f988bfc6f025d2519697256ffaf62884182c511bcd5c5d335 SHA512 86b2d563c2cff2b3d3cae3acdd399030cc785cc9859a06357a99565ef51f95122a8427c8c0883121fb0760613460a29c8cd8c7a7e3ac68115c10330b3b75cbe0
+DIST libinput-1.16.2.tar.xz 595632 BLAKE2B 0010ee7495e35d093d9cff72195433cfd571fb0b6d2bfbfa61b19eb6baa6cf6d00728673408d9d2427c3cb948e146ffd5a0184fe9a7ca3cc9bf8889b64a55115 SHA512 3394faeb0cdb0a543624e150f04a98f3bce8d67438e47455808bde8eec8ea9cdafb86056e5f8d3431352ae33714e490c55edeb51e0af1972c68fca07c1ef1daa
+DIST libinput-1.16.3.tar.xz 594948 BLAKE2B 6fad03dc8ab0280435b89a1049ed019d29e795279273277c9cad4676f484856d2677845ddc1c5102f2430645053a77c1cde48bb32530d4290ade576843a51ded SHA512 cdf87988b24dc0a44b7b6ed3e15e70c7702bf65f1cfe257924967677c7a1f1485011a9e30254ba8962c83885de78f824e7955cedb07322676332d42532ec4a39
EBUILD libinput-1.16.1.ebuild 2230 BLAKE2B 74ca4324289826313f0d01cc08308062483e5c4d204f87f30abe91d2eda88b1278fad9b62a4901c1fbf6b749abacb0f5f92e3b7c52708023c6435392244a46fa SHA512 6290bda45e9c91dafe2a38e3d08c5c83e46c88f13ba186184998c41b8d91f884768d5d12d70fc1072763ddce9ba7545e892699cbbc190e16d757ce32c1833c03
+EBUILD libinput-1.16.2.ebuild 2238 BLAKE2B 71fbec69d0bfddb68e3ad455a8b708a777ad56faa3aa35f5db13a9e5f431b33cc85448c564df453cc626546d0a59fc4b2ca3c42ddc7cb54d87d7b1bc3c712abe SHA512 3c9ab25eea207ef579459301470f5d50e168db887878b2bb841a5eee5231b7b78610ad45c80be26822f5b0a64c2b9037021f8aa669bdb03e002b5ab3221b89df
+EBUILD libinput-1.16.3.ebuild 2238 BLAKE2B 71fbec69d0bfddb68e3ad455a8b708a777ad56faa3aa35f5db13a9e5f431b33cc85448c564df453cc626546d0a59fc4b2ca3c42ddc7cb54d87d7b1bc3c712abe SHA512 3c9ab25eea207ef579459301470f5d50e168db887878b2bb841a5eee5231b7b78610ad45c80be26822f5b0a64c2b9037021f8aa669bdb03e002b5ab3221b89df
MISC metadata.xml 448 BLAKE2B c7a735047f8d22e10d1094dc4bbcbd118c025f318280dafd36029484956465c5e459326fb765f04fbdddc03743760a9008c6ac2494ad113387134fb4e79c4c48 SHA512 945c1005dccddac8085fd8b2be635c08d5b4da1f8264d564d10526d11cf814131d1fa5fd7620f35811a90b43686517519f4e9aba9253f5d5d5b69daa25be52bf
diff --git a/dev-libs/libinput/libinput-1.16.2.ebuild b/dev-libs/libinput/libinput-1.16.2.ebuild
new file mode 100644
index 000000000000..e2ae19212794
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.16.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 2014-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit meson python-any-r1 udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+[[ "$(ver_cut 3)" -gt 900 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc input_devices_wacom test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ $(python_gen_any_dep '
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
+ ')
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? ( dev-util/valgrind )
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev:=
+ virtual/udev
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/check-0.9.10 )"
+
+python_check_deps() {
+ has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
+ has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed "s@, '-Werror'@@" -i meson.build || die #744250
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ $(meson_use doc documentation)
+ $(meson_use input_devices_wacom libwacom)
+ $(meson_use test tests)
+ -Dudev-dir="${EPREFIX}$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/Documentation/.
+ fi
+}
+
+pkg_postinst() {
+ pkgname="dev-python/python-libevdev"
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! has_version "${pkgname}" ; then
+ einfo "${pkgname} must be installed to use the"
+ einfo "libinput measure and libinput replay tools."
+ fi
+
+ udevadm hwdb --update --root="${ROOT}"
+}
diff --git a/dev-libs/libinput/libinput-1.16.3.ebuild b/dev-libs/libinput/libinput-1.16.3.ebuild
new file mode 100644
index 000000000000..e2ae19212794
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.16.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 2014-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit meson python-any-r1 udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+[[ "$(ver_cut 3)" -gt 900 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc input_devices_wacom test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ $(python_gen_any_dep '
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
+ ')
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? ( dev-util/valgrind )
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev:=
+ virtual/udev
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/check-0.9.10 )"
+
+python_check_deps() {
+ has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
+ has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed "s@, '-Werror'@@" -i meson.build || die #744250
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ $(meson_use doc documentation)
+ $(meson_use input_devices_wacom libwacom)
+ $(meson_use test tests)
+ -Dudev-dir="${EPREFIX}$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/Documentation/.
+ fi
+}
+
+pkg_postinst() {
+ pkgname="dev-python/python-libevdev"
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! has_version "${pkgname}" ; then
+ einfo "${pkgname} must be installed to use the"
+ einfo "libinput measure and libinput replay tools."
+ fi
+
+ udevadm hwdb --update --root="${ROOT}"
+}