summaryrefslogtreecommitdiff
path: root/dev-libs/libjcat/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-libs/libjcat/files
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-libs/libjcat/files')
-rw-r--r--dev-libs/libjcat/files/libjcat-0.1.0-disable_installed_tests.patch45
-rw-r--r--dev-libs/libjcat/files/libjcat-0.1.0-use_right_python.patch29
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/libjcat/files/libjcat-0.1.0-disable_installed_tests.patch b/dev-libs/libjcat/files/libjcat-0.1.0-disable_installed_tests.patch
new file mode 100644
index 000000000000..823d713b7918
--- /dev/null
+++ b/dev-libs/libjcat/files/libjcat-0.1.0-disable_installed_tests.patch
@@ -0,0 +1,45 @@
+--- a/data/tests/colorhug/meson.build
++++ b/data/tests/colorhug/meson.build
+@@ -1,9 +1,11 @@
++if false
+ install_data([
+ 'firmware.bin',
+ 'firmware.bin.asc',
+ ],
+ install_dir: installed_test_datadir,
+ )
++endif
+
+ if get_option('pkcs7')
+ # generate self-signed detached signature
+@@ -16,7 +18,7 @@
+ '--load-certificate', pkcs7_certificate,
+ '--infile', '@INPUT@',
+ '--outfile', '@OUTPUT@'],
+- install: true,
++ install: false,
+ install_dir: installed_test_datadir,
+ )
+ endif
+--- a/data/tests/meson.build
++++ b/data/tests/meson.build
+@@ -2,7 +2,7 @@
+ input : 'libjcat.test.in',
+ output : 'libjcat.test',
+ configuration : conf,
+- install: true,
++ install: false,
+ install_dir: installed_test_datadir,
+ )
+
+--- a/libjcat/meson.build
++++ b/libjcat/meson.build
+@@ -225,7 +225,7 @@
+ '-DTESTDATADIR_SRC="' + testdatadir_src + '"',
+ '-DTESTDATADIR_DST="' + testdatadir_dst + '"',
+ ],
+- install : true,
++ install : false,
+ install_dir : installed_test_bindir
+ )
+ test('jcat-self-test', e)
diff --git a/dev-libs/libjcat/files/libjcat-0.1.0-use_right_python.patch b/dev-libs/libjcat/files/libjcat-0.1.0-use_right_python.patch
new file mode 100644
index 000000000000..9cbc63a08c01
--- /dev/null
+++ b/dev-libs/libjcat/files/libjcat-0.1.0-use_right_python.patch
@@ -0,0 +1,29 @@
+By default generate-version-script.py uses /usr/bin/python3, whatever
+version that may be - which causes problems if the default python3
+installation is one either built without XML support or not included
+in PYTHON_TARGETS of dev-python/setuptools. Make sure the script is
+invoked using the same interpreter as meson itself, as that one is
+already guaranteed to provide both 'xml' and 'pkg_resources'.
+
+--- a/libjcat/meson.build
++++ b/libjcat/meson.build
+@@ -129,6 +129,11 @@
+ install : true,
+ )
+
++ # Make sure generate-version-script.py is invoked by the same python as meson,
++ # as that one must already have both XML support and setuptools.
++ python = import('python')
++ python_interpreter = python.find_installation()
++
+ # Verify the map file is correct -- note we can't actually use the generated
+ # file for two reasons:
+ #
+@@ -141,6 +146,7 @@
+ input: jcat_gir[0],
+ output: 'jcat.map',
+ command: [
++ python_interpreter,
+ join_paths(meson.source_root(), 'contrib', 'generate-version-script.py'),
+ 'LIBJCAT',
+ '@INPUT@',