summaryrefslogtreecommitdiff
path: root/dev-libs/liblognorm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/liblognorm
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/liblognorm')
-rw-r--r--dev-libs/liblognorm/Manifest5
-rw-r--r--dev-libs/liblognorm/liblognorm-2.0.4.ebuild72
-rw-r--r--dev-libs/liblognorm/liblognorm-2.0.5.ebuild72
-rw-r--r--dev-libs/liblognorm/metadata.xml19
4 files changed, 168 insertions, 0 deletions
diff --git a/dev-libs/liblognorm/Manifest b/dev-libs/liblognorm/Manifest
new file mode 100644
index 000000000000..f03ce924df39
--- /dev/null
+++ b/dev-libs/liblognorm/Manifest
@@ -0,0 +1,5 @@
+DIST liblognorm-2.0.4.tar.gz 665898 BLAKE2B 80bcd114d2be81f8eea847e699b7e8ade9ca37d4376f64af81bfaba1a440e1efbab579235aba775c46a9d011e930453d2c001de525577b7775784e7152b3e700 SHA512 3c7cbf0c8c320708615218009354d198ba0893632ca464a07270f59d137753dfc7ad6dae66b565660f14e9285f9c8964824d36070b1872b6c633589b4996ba02
+DIST liblognorm-2.0.5.tar.gz 667709 BLAKE2B 9f2a774c2378caa460a1f11e21570e719f83e782c5731a35921099b1b31397495ea2a4baebd489d186526eb2d011f2ab30d971713a8083c1ae02168d3f632ce8 SHA512 2b36fabfa8b751127d47f307833414d339ae43bad5b687ce6ac42a961021f9a515703ca0c4808e098ef49be3a943abdbf307f90995a2331c6e266167ef041d00
+EBUILD liblognorm-2.0.4.ebuild 1494 BLAKE2B e650f9f6e067624d25834012df2b15c53290d36f49eaba52b020ef37eaf785f1e6c5c1c06dd4b4508535ef0c678fd6f51b0e0fad2d1a47d956dd742b474501c8 SHA512 7a525f0e554b45fe8087d6e9ef4949bedd50d81daf128aff6b0afbeeb64d9dac8d8cdc9e1c668a44b0ef09381067dce436a470f35dd81ccb4666ea7d5545e7a4
+EBUILD liblognorm-2.0.5.ebuild 1496 BLAKE2B 9208f635f3bd9a85f6f7d3575a975a4e32b68404721a235252ff78ec515524ed30030ed7749c37927f152c6472938bb761fb1dc256ccd04358509539e8eddae0 SHA512 c9ffbda9091b8382f4ce3d65a2471eb80cc66e41561ab084f8ad50db468c805f92134b47d2a4f38faccd4d27506a9a11a155949fe80590c5d3b19e87c6adb089
+MISC metadata.xml 582 BLAKE2B 59408e460cb8208149a93cbe049867d8cc202272aea9cd113a7f282eeb6f57b967abf7379241c8dd987e58f66f1efb36c29809176db34cdb3b2127a5ebe02f0c SHA512 7df1432cf2ddfe55c6a449d0179b771652a051d75fa34b8d3ea42d201bc64b3b18b2410ace68c263f14eb692661846a25cb0220de43abcaef13401e87f1173e2
diff --git a/dev-libs/liblognorm/liblognorm-2.0.4.ebuild b/dev-libs/liblognorm/liblognorm-2.0.4.ebuild
new file mode 100644
index 000000000000..635f5f3f9c52
--- /dev/null
+++ b/dev-libs/liblognorm/liblognorm-2.0.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Fast samples-based log normalization library"
+HOMEPAGE="http://www.liblognorm.com"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/rsyslog/${PN}.git"
+
+ inherit git-r3
+else
+ SRC_URI="http://www.liblognorm.com/files/download/${P}.tar.gz"
+ KEYWORDS="amd64 arm ~arm64 hppa x86 ~amd64-linux"
+fi
+
+LICENSE="LGPL-2.1 Apache-2.0"
+SLOT="0/5.1.0"
+IUSE="debug doc static-libs test"
+
+RDEPEND="
+ >=dev-libs/libestr-0.1.3
+ >=dev-libs/libfastjson-0.99.2:=
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/autoconf-archive-2015.02.04
+ virtual/pkgconfig
+ doc? ( >=dev-python/sphinx-1.2.2 )
+"
+
+DOCS=( ChangeLog )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # regexp disabled due to https://github.com/rsyslog/liblognorm/issues/143
+ local myeconfargs=(
+ --enable-compile-warnings=yes
+ --disable-Werror
+ $(use_enable doc docs)
+ $(use_enable test testbench)
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ --disable-regexp
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # When adding new tests via patches we have to make them executable
+ einfo "Adjusting permissions of test scripts ..."
+ find "${S}"/tests -type f -name '*.sh' \! -perm -111 -exec chmod a+x '{}' \; || \
+ die "Failed to adjust test scripts permission"
+
+ emake --jobs 1 check
+}
+
+src_install() {
+ default
+
+ find "${ED}"usr/lib* -name '*.la' -delete || die
+}
diff --git a/dev-libs/liblognorm/liblognorm-2.0.5.ebuild b/dev-libs/liblognorm/liblognorm-2.0.5.ebuild
new file mode 100644
index 000000000000..d4da89071921
--- /dev/null
+++ b/dev-libs/liblognorm/liblognorm-2.0.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Fast samples-based log normalization library"
+HOMEPAGE="http://www.liblognorm.com"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/rsyslog/${PN}.git"
+
+ inherit git-r3
+else
+ SRC_URI="http://www.liblognorm.com/files/download/${P}.tar.gz"
+ KEYWORDS="amd64 ~arm ~arm64 ~hppa x86 ~amd64-linux"
+fi
+
+LICENSE="LGPL-2.1 Apache-2.0"
+SLOT="0/5.1.0"
+IUSE="debug doc static-libs test"
+
+RDEPEND="
+ >=dev-libs/libestr-0.1.3
+ >=dev-libs/libfastjson-0.99.2:=
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/autoconf-archive-2015.02.04
+ virtual/pkgconfig
+ doc? ( >=dev-python/sphinx-1.2.2 )
+"
+
+DOCS=( ChangeLog )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # regexp disabled due to https://github.com/rsyslog/liblognorm/issues/143
+ local myeconfargs=(
+ --enable-compile-warnings=yes
+ --disable-Werror
+ $(use_enable doc docs)
+ $(use_enable test testbench)
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ --disable-regexp
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # When adding new tests via patches we have to make them executable
+ einfo "Adjusting permissions of test scripts ..."
+ find "${S}"/tests -type f -name '*.sh' \! -perm -111 -exec chmod a+x '{}' \; || \
+ die "Failed to adjust test scripts permission"
+
+ emake --jobs 1 check
+}
+
+src_install() {
+ default
+
+ find "${ED}"usr/lib* -name '*.la' -delete || die
+}
diff --git a/dev-libs/liblognorm/metadata.xml b/dev-libs/liblognorm/metadata.xml
new file mode 100644
index 000000000000..a1c7f71484f8
--- /dev/null
+++ b/dev-libs/liblognorm/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <slots>
+ <subslots>Reflect ABI of liblognorm.so.</subslots>
+ </slots>
+ <upstream>
+ <bugs-to>https://github.com/rsyslog/liblognorm/issues</bugs-to>
+ <remote-id type="github">rsyslog/liblognorm</remote-id>
+ </upstream>
+</pkgmetadata>