summaryrefslogtreecommitdiff
path: root/dev-libs/liblouis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/liblouis
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/liblouis')
-rw-r--r--dev-libs/liblouis/Manifest3
-rw-r--r--dev-libs/liblouis/liblouis-2.5.3.ebuild64
-rw-r--r--dev-libs/liblouis/metadata.xml11
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-libs/liblouis/Manifest b/dev-libs/liblouis/Manifest
new file mode 100644
index 000000000000..5c976516184c
--- /dev/null
+++ b/dev-libs/liblouis/Manifest
@@ -0,0 +1,3 @@
+DIST liblouis-2.5.3.tar.gz 3785311 BLAKE2B 15130dfa6c32b9c12b6ffccf4a8b2185bcc8fe483e8822d4fdd9f1c1cd0c3e8f33325419f75a9eb23e1414743fe01b44041c836a06e4ff040708b95998251854 SHA512 5aa65f3a0b7cef37fe7cd8ccf09df8c40f38d183a88d1be9f1251b40406204e57a8d95716bf1de3569b09b640be613cc3e0bd0e05dc4d544face00bfc8d75ac7
+EBUILD liblouis-2.5.3.ebuild 1418 BLAKE2B beef7c46b9b71fa1a396581e83cc0c8026da09730981b764f622741a31ef25c1f432c2f8442aea66a0e0cbac40d3db430854e367cc0432661d33bc1fd37ec94b SHA512 60dc647ab82f83db96a7b72f636a90cf7c0cf41b9b08511b7584c7fbee3f9ba1708401cbf343563f42ec43c9c0321a3152581087976ca645d8e04f8f2b3a355c
+MISC metadata.xml 351 BLAKE2B 0fa7c957682fe363ddd29442ae153152469cc64ebf9005361c4b82f180c380485adf0b04467b147a441c6656ddcc9e44967fd692ed9f835d70653dbae9b9be1a SHA512 377a2d9ea4bc6007a60fcaf0284bd47af78b6fe2c901916f9cd7d6ab0f7a5225baf7314b47b0c3b00cd162278f910206bd99469bdef0165cd6e19c1eff73714d
diff --git a/dev-libs/liblouis/liblouis-2.5.3.ebuild b/dev-libs/liblouis/liblouis-2.5.3.ebuild
new file mode 100644
index 000000000000..07927ad714db
--- /dev/null
+++ b/dev-libs/liblouis/liblouis-2.5.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE='wide-unicode(+)'
+DISTUTILS_OPTIONAL=1
+inherit distutils-r1
+
+DESCRIPTION="An open-source braille translator and back-translator"
+HOMEPAGE="https://github.com/liblouis/liblouis"
+SRC_URI="https://liblouis.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86"
+IUSE="python"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+src_prepare() {
+ default
+
+ if use python; then
+ pushd python > /dev/null
+ distutils-r1_src_prepare
+ popd > /dev/null
+ fi
+}
+
+src_configure() {
+ econf --enable-ucs4
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ pushd python > /dev/null
+ # setup.py imports liblouis to get the version number,
+ # and this causes the shared library to be dlopened
+ # at build-time. Hack around it with LD_PRELOAD.
+ # Thanks ArchLinux.
+ LD_PRELOAD+=':../liblouis/.libs/liblouis.so'
+ distutils-r1_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ if use python; then
+ pushd python > /dev/null
+ LD_PRELOAD+=':../liblouis/.libs/liblouis.so' \
+ distutils-r1_src_install
+ popd > /dev/null
+ fi
+
+ dodoc README AUTHORS NEWS ChangeLog || die
+ dohtml doc/liblouis.html
+}
diff --git a/dev-libs/liblouis/metadata.xml b/dev-libs/liblouis/metadata.xml
new file mode 100644
index 000000000000..431c3019b962
--- /dev/null
+++ b/dev-libs/liblouis/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>accessibility@gentoo.org</email>
+ <name>Gentoo Accessibility Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">liblouis/liblouis</remote-id>
+ </upstream>
+</pkgmetadata>