summaryrefslogtreecommitdiff
path: root/dev-libs/libmacaroons/libmacaroons-0.3.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-14 10:46:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-14 10:46:43 +0100
commitd938920a33f03124f4e211a67d9291283442caa1 (patch)
tree8df88b987b9cf96366e7bdab6bec0f5606c6153d /dev-libs/libmacaroons/libmacaroons-0.3.0-r2.ebuild
parent8d3092381b8c63ad0261911737e91cc4fda109c9 (diff)
gentoo auto-resync : 14:09:2023 - 10:46:43
Diffstat (limited to 'dev-libs/libmacaroons/libmacaroons-0.3.0-r2.ebuild')
-rw-r--r--dev-libs/libmacaroons/libmacaroons-0.3.0-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/libmacaroons/libmacaroons-0.3.0-r2.ebuild b/dev-libs/libmacaroons/libmacaroons-0.3.0-r2.ebuild
new file mode 100644
index 000000000000..ba3c057214a9
--- /dev/null
+++ b/dev-libs/libmacaroons/libmacaroons-0.3.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C library for generation and use of macaroons authorization credentials"
+HOMEPAGE="https://github.com/rescrv/libmacaroons"
+SRC_URI="https://github.com/rescrv/libmacaroons/archive/refs/tags/releases/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/json-c:=
+ dev-libs/libsodium:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}"/${PN}-releases-${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-json-c.patch
+ "${FILESDIR}"/${P}-no-python.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-json-support
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}