summaryrefslogtreecommitdiff
path: root/dev-libs/libmail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libmail
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libmail')
-rw-r--r--dev-libs/libmail/Manifest4
-rw-r--r--dev-libs/libmail/files/libmail-0.3-respect-cflags.patch37
-rw-r--r--dev-libs/libmail/libmail-0.3-r3.ebuild53
-rw-r--r--dev-libs/libmail/metadata.xml11
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-libs/libmail/Manifest b/dev-libs/libmail/Manifest
new file mode 100644
index 000000000000..7ec77eebdc1b
--- /dev/null
+++ b/dev-libs/libmail/Manifest
@@ -0,0 +1,4 @@
+AUX libmail-0.3-respect-cflags.patch 879 BLAKE2B c1950a6b4052f75eb3f95ad35d7c70d28b2cfd7fdf8eefd406a92b91f87085d91370f36bc74bc4410994ae31ee8a1f860acadee145ccc4cd0e9e69f803707a93 SHA512 b5450bf020a84473f173f4985a5192609629e312a44da40c11cd8e806fb6d6b7d4e97df9821823d4da41d9588c9218dfb0d20a18b38ab06074001ad3ea3beb18
+DIST libmail-0.3.tar.bz2 271946 BLAKE2B f03b5a07bb78423bc37111448e0b0b812d51172210a555a1cc8279ce66f62ea5033954bb37c01d6d225d53bab4996366ae803fab9a96ef97a841cbd88896454e SHA512 df4e0e549867f7cf73db8c965a28c14e3e089e54a8272b70be8b00c896dcd91d68625e2287a15d353eff75ec05e702e6d113f8122ed0e9d294766fe4f467e9d3
+EBUILD libmail-0.3-r3.ebuild 1232 BLAKE2B ae096479e2e34087cd801d98a8f6415579dc5115ace6182de7569140ff6b98c6e3107a1451e9b2d4c0aa6df5c5a20e1862443913311d8313b932f4907c437488 SHA512 250af3049f272445fa3e1de9dff561fbe6055ca24aec542ae5a634dc1ad01ff530253567abfc435e4124d425cd2585941fbbb2e44e0245e2664d23cad60dc87c
+MISC metadata.xml 325 BLAKE2B e7c785c98f24aae1ee2d498d1d0ac93e7d60dfde1ea9289a36f90d997a56b3980531cfc6c412bfc211723fa6887a2958e468418613ead77c7b7b4051006248f4 SHA512 027f60bf3d6fcab565ddad1434d9df43f6e2d0e71c85f670a7c9723dec14ecbf7e8dddd4c15f1290b0bfdab453f796e58dc241752e5605023fe323ae4fac0f41
diff --git a/dev-libs/libmail/files/libmail-0.3-respect-cflags.patch b/dev-libs/libmail/files/libmail-0.3-respect-cflags.patch
new file mode 100644
index 000000000000..7e22de4c7576
--- /dev/null
+++ b/dev-libs/libmail/files/libmail-0.3-respect-cflags.patch
@@ -0,0 +1,37 @@
+--- configure.ac.orig 2013-01-31 16:18:06.537834009 +0400
++++ configure.ac 2013-01-31 16:19:00.138835711 +0400
+@@ -12,7 +12,7 @@
+ AC_PROG_MAKE_SET
+ AC_PROG_LIBTOOL
+
+-CFLAGS="-D_GNU_SOURCE -Wall -Wunused -Wstrict-prototypes"
++CFLAGS="-D_GNU_SOURCE -Wall -Wunused -Wstrict-prototypes ${CFLAGS}"
+
+ use_sasl=false
+ use_apop=false
+@@ -99,7 +99,6 @@
+ ;;
+ yes)
+ AC_DEFINE(NDEBUG, [1], [Use debug functionality])
+- CFLAGS="$CFLAGS -g"
+ optimize="no"
+ ;;
+ *)
+@@ -119,7 +118,6 @@
+ ;;
+ yes)
+ AC_DEFINE(NDEBUG, [1], [Use debug functionality])
+- CFLAGS="$CFLAGS -pg -g"
+ optimize="yes"
+ ;;
+ *)
+@@ -127,9 +125,6 @@
+ ;;
+ esac
+ ])
+-if test $optimize = "yes"; then
+- CFLAGS="$CFLAGS -O2"
+-fi
+ AM_CONDITIONAL([LIBMAIL_USE_SASL], [test x$use_sasl = xtrue])
+ AM_CONDITIONAL([LIBMAIL_USE_APOP], [test x$use_apop = xtrue])
+ AM_CONDITIONAL([LIBMAIL_USE_TLS], [test x$use_tls = xtrue])
diff --git a/dev-libs/libmail/libmail-0.3-r3.ebuild b/dev-libs/libmail/libmail-0.3-r3.ebuild
new file mode 100644
index 000000000000..c20fa7c5a900
--- /dev/null
+++ b/dev-libs/libmail/libmail-0.3-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="A mail handling library"
+HOMEPAGE="http://libmail.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="apop debug gnutls profile sasl static-libs"
+
+DEPEND="gnutls? ( >=net-libs/gnutls-2 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+# Do not unset user's CFLAGS, bug #454558
+PATCHES=( "${FILESDIR}/${P}-respect-cflags.patch" )
+
+src_prepare() {
+ # Drop quotes from ACLOCAL_AMFLAGS otherwise aclocal will fail
+ # see 447760
+ sed -i -e "/ACLOCAL_AMFLAGS/s:\"::g" Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable apop)
+ $(use_enable debug)
+ $(use_enable gnutls tls)
+ $(use_enable profile)
+ $(use_enable sasl)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # headers, that are wrongly skipped from installing
+ insinto /usr/include/libmail
+ doins libmail/libmail_intl.h
+ doins config.h
+}
diff --git a/dev-libs/libmail/metadata.xml b/dev-libs/libmail/metadata.xml
new file mode 100644
index 000000000000..b77b86fc4804
--- /dev/null
+++ b/dev-libs/libmail/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <use>
+ <flag name="apop">Enables the APOP authentication method</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">libmail</remote-id>
+ </upstream>
+</pkgmetadata>