summaryrefslogtreecommitdiff
path: root/dev-libs/libmaxminddb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-libs/libmaxminddb
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-libs/libmaxminddb')
-rw-r--r--dev-libs/libmaxminddb/Manifest4
-rw-r--r--dev-libs/libmaxminddb/libmaxminddb-1.6.0.ebuild46
-rw-r--r--dev-libs/libmaxminddb/libmaxminddb-9999.ebuild20
3 files changed, 65 insertions, 5 deletions
diff --git a/dev-libs/libmaxminddb/Manifest b/dev-libs/libmaxminddb/Manifest
index ce59d3ad5568..5bf0d87fad84 100644
--- a/dev-libs/libmaxminddb/Manifest
+++ b/dev-libs/libmaxminddb/Manifest
@@ -1,4 +1,6 @@
DIST libmaxminddb-1.5.2.tar.gz 604683 BLAKE2B 4dea7413be59169104adf3dc5dfe3e4f3bdb4639bbb4a0c6365d93216e279d505f01e32f737bf66d9f5b98f65f3eaefa46f630458bd6032a32be8c74acf12a1b SHA512 074ef6b62a74cede7be332eaeff5aa7442f43de92d39ea65b38430f0e1b65a5515f4343894ca5c28a7d50181eaec44e8db7083461b9e12e7014d2d1e0ff033b8
+DIST libmaxminddb-1.6.0.tar.gz 605099 BLAKE2B 6868e42b8a166d75f6fa3a1da0fc2bd47a381ff960496ec9348b88c72b1bae180e3c0ce8989149e60d7d9c795d6baedb8e9d984098914064db985f2d201983c2 SHA512 9394e8dd959982d4ef5d15a928d32700722ed9d6c9988d9cc1bf2f4e67de0a53cc6987e90aaef3a6926c9ff36ac378f7a1fe47818fda4f5a3a22539210b2d004
EBUILD libmaxminddb-1.5.2.ebuild 669 BLAKE2B 4b789f4f6389f90041907c455fe34765881a5722234800371371db435ee4fb9827b01b6a88209db22ee3ca74abcaa97706b3993e906b76277de0afb6356bc7fe SHA512 d51716ef0432573944954ac8cfacb00d559f78bea9b5b3ea82303ba06a554107ab993ff5af06e45c2a614481eb75370453f49633f5a8357a026add5ccaf731de
-EBUILD libmaxminddb-9999.ebuild 629 BLAKE2B ffc5f031cf5cb70207ece2fbf937f44f38a53d65bb9153ed6edcb52c663375c687b5cc549729ea8f7a93ee6b503d8f54e0f38365e113331d06aa8f53413e8ab4 SHA512 1e331eca7e54007e1c6a3e41d4a0aff03733a9e76a7d1b6a6b3941e82005ec48272c820f59c726875fd67101614fe094562977991a6552736ff42484723ecd3e
+EBUILD libmaxminddb-1.6.0.ebuild 886 BLAKE2B d5f7b28779a576a1a0d2046652ed89b149f89a17136751de7c9f2f699d64667ccc25edac1bacc24053dc4327880e03025d0983359c715be9c901cecca26c6de8 SHA512 0636f14a7390c502005ec72458b9e4421ecb3e04f996466a936d864f1d92341d4231d0c5461f0eecef92dd2c66fa5e74f1844eb13200343ef307334ecd17fc51
+EBUILD libmaxminddb-9999.ebuild 886 BLAKE2B d5f7b28779a576a1a0d2046652ed89b149f89a17136751de7c9f2f699d64667ccc25edac1bacc24053dc4327880e03025d0983359c715be9c901cecca26c6de8 SHA512 0636f14a7390c502005ec72458b9e4421ecb3e04f996466a936d864f1d92341d4231d0c5461f0eecef92dd2c66fa5e74f1844eb13200343ef307334ecd17fc51
MISC metadata.xml 365 BLAKE2B 3acd92dfb25bcbae837f784572887ffc5542121a91d6f2077f3410d03ddc3290d8b3485c4aa8d1c97af8f4f85a3dc8a621fc9eb5affacc1e27d41d4760ed53a4 SHA512 4e7a17cbf391683173f573d79f273e92184695e37bc68070c03ef4969e8b0e8a35a34b8b87d6582f365b93683b143f216a5a2365c9fe63a6f36ddd78e2ff8730
diff --git a/dev-libs/libmaxminddb/libmaxminddb-1.6.0.ebuild b/dev-libs/libmaxminddb/libmaxminddb-1.6.0.ebuild
new file mode 100644
index 000000000000..2428e17f2542
--- /dev/null
+++ b/dev-libs/libmaxminddb/libmaxminddb-1.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="C library for the MaxMind DB file format"
+HOMEPAGE="https://github.com/maxmind/libmaxminddb"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/maxmind/libmaxminddb.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/maxmind/libmaxminddb/releases/download/${PV}/${P}.tar.gz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0/0.0.7"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-perl/IPC-Run3 )"
+
+DOCS=( Changes.md )
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == *9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ tc-export AR CC
+
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/libmaxminddb/libmaxminddb-9999.ebuild b/dev-libs/libmaxminddb/libmaxminddb-9999.ebuild
index 455b87166499..2428e17f2542 100644
--- a/dev-libs/libmaxminddb/libmaxminddb-9999.ebuild
+++ b/dev-libs/libmaxminddb/libmaxminddb-9999.ebuild
@@ -3,11 +3,18 @@
EAPI=7
-inherit autotools toolchain-funcs git-r3
+inherit toolchain-funcs
DESCRIPTION="C library for the MaxMind DB file format"
HOMEPAGE="https://github.com/maxmind/libmaxminddb"
-EGIT_REPO_URI="https://github.com/maxmind/libmaxminddb.git"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/maxmind/libmaxminddb.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/maxmind/libmaxminddb/releases/download/${PV}/${P}.tar.gz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
LICENSE="Apache-2.0"
SLOT="0/0.0.7"
@@ -20,15 +27,20 @@ DOCS=( Changes.md )
src_prepare() {
default
- eautoreconf
+
+ if [[ ${PV} == *9999 ]] ; then
+ eautoreconf
+ fi
}
src_configure() {
- econf --disable-static
tc-export AR CC
+
+ econf --disable-static
}
src_install() {
default
+
find "${ED}" -name '*.la' -delete || die
}