summaryrefslogtreecommitdiff
path: root/dev-libs/libnest2d/libnest2d-0.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /dev-libs/libnest2d/libnest2d-0.4-r2.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'dev-libs/libnest2d/libnest2d-0.4-r2.ebuild')
-rw-r--r--dev-libs/libnest2d/libnest2d-0.4-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libnest2d/libnest2d-0.4-r2.ebuild b/dev-libs/libnest2d/libnest2d-0.4-r2.ebuild
new file mode 100644
index 000000000000..88a93621c9d5
--- /dev/null
+++ b/dev-libs/libnest2d/libnest2d-0.4-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Library and framework for the 2D bin packaging problem"
+HOMEPAGE="https://github.com/tamasmeszaros/libnest2d"
+SRC_URI="https://github.com/tamasmeszaros/libnest2d/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE="examples static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-libs/boost
+ dev-libs/clipper
+ sci-libs/nlopt
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-cpp/catch-2.9.1 )
+ "
+
+PATCHES=(
+ "${FILESDIR}"/${P}-add-disallowed-areas.patch
+ "${FILESDIR}"/${P}-add-soversion-to-shared-library.patch
+ "${FILESDIR}"/${P}-fix-cpp-version.patch
+ "${FILESDIR}"/${P}-gnu-install-dirs.patch
+ )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DLIBNEST2D_BUILD_EXAMPLES=$(usex examples)
+ -DLIBNEST2D_HEADER_ONLY=$(usex static-libs OFF ON)
+ -DLIBNEST2D_BUILD_UNITTESTS=$(usex test)
+ -DCMAKE_INSTALL_LIBDIR=$(get_libdir)
+ )
+ cmake_src_configure
+}