summaryrefslogtreecommitdiff
path: root/dev-libs/libstrophe/libstrophe-0.12.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 15:32:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 15:32:39 +0100
commitc74abf990d32765245eeb94b36ad4af642cae8c0 (patch)
treeb700660e782342b531312e3855b949f5b2fbbc60 /dev-libs/libstrophe/libstrophe-0.12.3.ebuild
parent5a21cec0c36dba03507dcbd5e8ab6698d00b39bf (diff)
gentoo auto-resync : 17:08:2023 - 15:32:39
Diffstat (limited to 'dev-libs/libstrophe/libstrophe-0.12.3.ebuild')
-rw-r--r--dev-libs/libstrophe/libstrophe-0.12.3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/libstrophe-0.12.3.ebuild b/dev-libs/libstrophe/libstrophe-0.12.3.ebuild
new file mode 100644
index 000000000000..bfa7f2b9db7f
--- /dev/null
+++ b/dev-libs/libstrophe/libstrophe-0.12.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
+HOMEPAGE="https://strophe.im/libstrophe/"
+SRC_URI="
+ https://github.com/strophe/${PN}/releases/download/${PV}/${P}.tar.xz
+"
+LICENSE="|| ( MIT GPL-3 )"
+# Subslot: ${SONAME}.1 to differentiate from previous versions without SONAME
+SLOT="0/0.1"
+KEYWORDS="~amd64 ~arm64"
+IUSE="doc expat gnutls"
+
+RDEPEND="
+ expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2:2 )
+ gnutls? ( net-libs/gnutls:0= )
+ !gnutls? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=( ChangeLog )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.12.3-allow-tests-when-static.patch"
+)
+
+src_configure() {
+ # shellcheck disable=SC2207
+ local myeconf=(
+ --enable-tls
+ $(use_with !expat libxml2)
+ $(use_with gnutls)
+ )
+ econf "${myeconf[@]}"
+}
+
+src_compile() {
+ default
+ if use doc; then
+ doxygen || die
+ HTML_DOCS=( docs/html/* )
+ fi
+}
+
+src_install() {
+ default
+ use doc && dodoc -r examples
+ find "${D}" -type f \( -name '*.la' -o -name '*.a' \) -delete || die
+}